Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,477
Community Members
 
Community Events
168
Community Groups

Jira Project Configurator issue exporting a Service Desk Project.

Hi! I am using the Adaptavist Project Configurator and there is one thing I haven't been able to do, and it is to export a Service Desk application. All other jira projects have worked without any problem, but when exporting the Service Desk project (with groups and users and even without any users or groups) it gets stuck in 35% and the database file gets bigger and bigger. 

I have by now been waiting for exactly 2 days and 1 hour for the task to complete the export. And the database size (internal jira database) has been growing and is now around 15,8gb big. 

I dont think it is normal to be waiting for over 2 days for a project to export, when I have been able to export other 24 jira software projects in a couple of minutes all together. 

I have tried with different configurations and nothing. Does anyone have any clue? Is there a special configuration to a Service Desk export to work with Adaptavist Project Configurator?

I will attach some pictures so you can see. 
Thanks in advance!

Screen Shot 2018-09-23 at 01.00.16.pngScreen Shot 2018-09-23 at 01.01.34.png

2 answers

Hi Andres,

Thank you for your question, 

I can confirm that Project Configurator does not execute any write operations to the database and only executes select operations to extract data. 

We also notice that the H2 database is only an evaluation database which runs completely in memory so it could be affected by other processes running on the machine. 

Would it be possible for you to try installing another database server such as MYSQL or Postgress locally onto your machine before trying a new export to see if the error still occurs so we can rule out that the H2 database may be the cause of the issue.

If you still encounter this error after using a different database then this means that their must be some configuration in the project that is triggering a process when the project is exported which is writing to the database and causing its size to increase. We would recommend reviewing the project and removing any scripts or automatons that are found attached to the project to see if removing these resolves this error.

Finally I would advise using a database viewer for the database being used to review which tables are increasing in size when the export is being ran as this my help to narrow down any configuration that is causing the database to grow in size.

If this response has answered your question can you please mark it as accepted so that other users can see it is correct when searching for similar answers.

Regards,

Kristian

0 votes
Keri Atlassian Team Sep 24, 2018

Hi Andres, 

 

I can't say for certain if this is a specific issue with project configurator - but the H2 database is an in memory database, so if the file has increased in size to 15GB I would be concerned about the amount of memory you have for the server you're running. 

 

This may be slow now due to the consumption of all of the memory on the system.  Is it possible for you to try using a physical database for Jira such as MySQL or PostgreSQL instead of the H2 database?  See Switching Databases

 

Cheers, 

Keri

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events