Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,459,886
Community Members
 
Community Events
176
Community Groups

How to use <jira>/rest/scriptrunner-jira/latest/appaudit/workflow

Does anyone know how to use:

<jira>/rest/scriptrunner-jira/latest/appaudit/workflow

My understanding from a recent demo was that it would give output that could be viewed with columns like:

Workflow, Workflow Status, Transition, Type, Module, Plugin, URL

but when I try it i get page with:

<status>
<status-code>404</status-code>
<message>
null for uri: <jira>/rest/scriptrunner-jira/latest/appaudit/workflow
</message>
</status>

3 answers

1 accepted

2 votes
Answer accepted

Hi @Sherryl Radbil I would recommend you to raise a support ticket with on: https://productsupport.adaptavist.com/servicedesk/customer/portal/55

I'm pretty sure they will help you solve that one.
It might be some infrastructure challenge/issue.

Forget what I just said, @Sherryl Radbil lol

I just realised that you are using the SR URL.

This feature was initially released as a dark feature in SR, but now it is a stand-alone App, called Microscopehttps://marketplace.atlassian.com/apps/1225065/microscope-power-audit-for-jira-admins?hosting=server&tab=overview

Microscope charges 10 dollars for the license, but I'm glad to give you a 100% discount voucher, considering you are an SR user.

Please reach out to me on my e-mail: aserrano@adaptavist.com

BTW, I'm ScriptRunner Product Manager

0 votes
Daniel Ebers Community Leader May 24, 2021

Hi @Sherryl Radbil

testing in my environment I was able to request the CSV - is there probably some kind of reverse proxy intercepting your connection or some other setting blocking access.

Even when I tried in unauthenticated I got back a '401' but the '404' error suggests the endpoint would not be there. Another idea could be to check if there are updates for Script Runner which could be installed but then also let Adaptavist support have a look.

Regards,
Daniel

Hey @Sherryl Radbil,

Have you tried replacing <jira> with the base URL of your Jira instance?

For example, if your base URL is http://localhost:8080, a .csv file should be generated when you access http://localhost:8080/rest/scriptrunner-jira/latest/appaudit/workflow

Hi Winnie,

Thank you for the response. Yes, of course I substituted <jira> for the base URL as show on the System > General Configuration.

I just didn't see fit to unnecessarily expose the exact detail.

So let's say I use something we all know about:

https://jira.atlassian.com/rest/scriptrunner-jira/latest/appaudit/workflow

I also get a 404, though in this case I have no access to such data.

Does this work in your environment?

Thanks,

Sherryl

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events