The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting "resource busy" errors

Brandon Ching
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 21, 2011

Whenever I try to commit changes, I am getting a "resource busy" error in SourceTree and the commit rolls back and fails. I'm on a Mac (10.7) using SourceTree 1.2.91 with Mercurial repos. All other features seem to work fine. If I go to the command line, I can commit fine. Also, I'm accessing the source through SMB on a remote system that I have mounted. Any ideas?

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Answer accepted
stevestreeting
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
December 21, 2011

It's generally a very bad idea to use SMB mounted repositories, this is not officially supported. SMB is a pretty dumb protocol and doesn't allow for the kind of locking that both git and hg expect to be able to do on the repo to cope with parallel requests etc. Since SourceTree makes heavy use of parallelisation in order to provide a fast user experience, SMB is not supported. I've seen it work, and I haven't seen this error before, but I'm fairly sure this is it. I've also seen SMB hosted repositories get corrupted by git before so I personally wouldn't touch them with a barge pole.

You'd be far better (performance and resilience wise) to use a local repo and push to the remote when you need to, preferably over a more robust protocol like SSH but SMB may be good enough just for the push.

Brandon Ching
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 21, 2011

Thanks. That seemed to be it. I mounted using SSHFS and problem solved.

TAGS
AUG Leaders

Atlassian Community Events