The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

error when trying to export a space: column backuprest0_.cancel_time does not exist

Emmanouil Lazarides
December 18, 2023

Hi all -

I'm trying to export a space from Confluence Server 8.4.5, and it invariably comes back with an error, amounting to a missing column in some database table. Here is the relevant extract from the log:

2023-12-18 14:52:04,445 WARN [https-jsse-nio2-9443-exec-18] [engine.jdbc.spi.SqlExceptionHelper] logExceptions SQ
L Error: 0, SQLState: 42703
-- url: /rest/api/backup-restore/jobs | userName: xxxxxx | referer: https://xxxx.xxxxxx.xxx:8443/plugi
ns/servlet/space-tool-backup/SPACE | traceId: e0d8e3e1275ffc84

2023-12-18 14:52:04,445 ERROR [https-jsse-nio2-9443-exec-18] [engine.jdbc.spi.SqlExceptionHelper] logExceptions E
RROR: column backuprest0_.cancel_time does not exist\n Position: 406
-- url: /rest/api/backup-restore/jobs | userName: xxxxxx | referer: https://xxxx.xxxxxx.xxx:8443/plugi
ns/servlet/space-tool-backup/SPACE | traceId: e0d8e3e1275ffc84

2023-12-18 14:52:04,447 WARN [https-jsse-nio2-9443-exec-18] [confluence.impl.hibernate.ConfluenceHibernateTransac
tionManager] doRollback Performing rollback. Transactions:\n ->[com.atlassian.confluence.impl.backuprestore.dao.
BackupRestoreJobDao.findJobs]: PROPAGATION_REQUIRED,ISOLATION_DEFAULT,readOnly (Session #1715670146)
-- url: /rest/api/backup-restore/jobs | userName: xxxxxx | referer: https://xxxx.xxxxxx.xxx:8443/plugi
ns/servlet/space-tool-backup/SPACE | traceId: e0d8e3e1275ffc84

2023-12-18 14:52:04,451 ERROR [https-jsse-nio2-9443-exec-18] [rest.api.model.ExceptionConverter] convertServiceEx
ception No status code found for exception, converting to internal server error :
-- url: /rest/api/backup-restore/jobs | userName: xxxxxx | referer: https://xxxx.xxxxxx.xxx:8443/plugi
ns/servlet/space-tool-backup/SPACE | traceId: e0d8e3e1275ffc84
javax.persistence.PersistenceException: org.hibernate.exception.SQLGrammarException: could not extract ResultSet
at org.hibernate.internal.ExceptionConverterImpl.convert(ExceptionConverterImpl.java:154)
at org.hibernate.query.internal.AbstractProducedQuery.list(AbstractProducedQuery.java:1626)

...

Any ideas how to fix this? Even knowing what table to look at in the database might be helpful.

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

1 vote
Fabio Racobaldo _Catworkx_
Community Champion
March 13, 2025

Hi @Emmanouil Lazarides ,

it seems an issue at db level. Could you share DBMS and collation?

Fabio

DEPLOYMENT TYPE
SERVER
VERSION
8.5.4
TAGS
AUG Leaders

Atlassian Community Events