The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Recurring error in Confluence logs

Jeramy
Contributor
September 11, 2023

This morning our Confluence instance crash and while it was restarting, I started looking at the logs and discovered this error message 28 times.

 

2023-09-08 18:53:44,817 ERROR [http-nio-8090-exec-925] [[Standalone].[localhost].[/].[action]] log Servlet.service() for servlet [action] in context with path [] threw exception
java.lang.NullPointerException: Deflater has been closed
at java.base/java.util.zip.Deflater.ensureOpen(Unknown Source)
at java.base/java.util.zip.Deflater.deflate(Unknown Source)
at java.base/java.util.zip.Deflater.deflate(Unknown Source)
at java.base/java.util.zip.GZIPOutputStream.finish(Unknown Source)
at java.base/java.util.zip.DeflaterOutputStream.close(Unknown Source)
...

 

I've done some research, but I cannot seem to find a solution or a reason why it occurs. 

Any suggestions?

 

Thank you.

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

0 votes
Brant Schroeder
Community Champion
September 11, 2023

@Jeramy Have you cleared the plugin/app cache?  You can also try restarting after you put it in safe mode to see if the issue still exists.  

Jeramy
Contributor
September 12, 2023

@Brant Schroeder - I have not tried clearing the cache files yet. Unfortunately, I still see this error after restarting the Confluence service. 

I will try that to see if it fixes the issue. 

Thank you.

Brant Schroeder
Community Champion
May 21, 2024

@Jeramy did that resolve the issue?

Jeramy
Contributor
May 22, 2024

@Brant Schroeder - I will have to doublecheck. I lost track of time and moved onto different things. Thanks for checking up. :)

Like Brant Schroeder likes this
Brant Schroeder
Community Champion
September 11, 2024

@Jeramy if this worked to resolve the issue could you accept the answer to help others?

DEPLOYMENT TYPE
SERVER
TAGS
AUG Leaders

Atlassian Community Events