The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

JIRAISSUES macro results in expired certificate error in Confluence

Ken Hymes
Contributor
August 13, 2012

Using JRIA 5.1.1 and Confluence 4.1.5.

I've created a page that has the JIRAISSUES macro embedded in it. After I added the properties to the macro and ran a test, I got an expired certificate error message (attached). My admin tells me we have trusted application permissions set between JIRA and Confluence. Anyone have any ideas on how to resolve this error?

4 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

1 vote
Answer accepted
Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
August 13, 2012

Ah, I've run into this - your administrators need to generate or get a new certificate and install it on the Jira server in place of the old one.

Ken Hymes
Contributor
August 13, 2012

Thanks, Nic. I will pass that bit of info along to our admin! Much obliged...

3 votes
Faisal
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
August 13, 2012

Hi Ken,

This problem could arise because there is a time difference between JIRA and Confluence server. Hence in order to fix this, you may try to synchronize the clock for both of the server.

More details on this, kindly refer to the following KB article:
https://confluence.atlassian.com/display/JIRAKB/CertificateTooOldException+when+Configuring+Trusted+Communication

Hope this helps!

Ken Hymes
Contributor
August 14, 2012

Thanks, Ahmad. I've now reviewed the Confluence issue and passed along to my admin. Hoping that resolves the issue! :-)

0 votes
Chris Astall
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
March 12, 2013

How can one get around this without regenerating the cert? It should be possible to tell the macro to ignore the server error.

0 votes
Nic Brough -Adaptavist-
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Champions.
August 13, 2012

Ah, I've run into this - your administrators need to generate or get a new certificate and install it on the Jira server in place of the old one.

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

TAGS
AUG Leaders

Atlassian Community Events