Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Confluence stopped working after trying to run Jira and Confluence together on the same machine.

Raunaq Kumar
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 4, 2019

I installed Jira package first. Worked fine. Stopped Jira server.

Installed Confluence package afterwards on a separate port. Worked fine.

Wanted to connect both of them so I started Jira server and immediately my confluence server crashed. Giving me the following error:

Cause:

com.atlassian.util.concurrent.LazyReference$InitializationException: java.lang.IllegalStateException: Spring Application context has not been set
    at com.atlassian.util.concurrent.LazyReference.getInterruptibly(LazyReference.java:149)

caused by: java.lang.IllegalStateException: Spring Application context has not been set
    at com.atlassian.spring.container.SpringContainerContext.getComponent(SpringContainerContext.java:48)

 

Afterwards, I have uninstalled and reinstalled confluence and jira but it didn't help.

As of now, I don't need Jira so it it uninstalled. I only need Confluence. 

Kindly let me know what I am doing wrong.

 

Confluence Error.png

1 answer

0 votes
Diego
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
July 8, 2019

Hello there @Raunaq Kumar !

This issue is know and listed in one of our articles here:

There are many causes for this issue. For that matter, I recommend that we start by checking the permissions for both <confluence-home> and <confluence-install> folders.

The essential permissions for the user running Confluence are read, write and execute on both these folders, sub-folders and files.

Remember that running Confluence as root is not recommended. The installer automatically creates a user for the system to use Confluence. You can check more information about the installation process here:

Keep in mind that the install procedure is different based on your base operational system.

Let us hear from you Raunaq! Looking forward to your reply.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events