The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

selfhosted Runner on EKS having Invalid OAuth client credentials

mohit namdeo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
May 29, 2025

I have used Autoscaler for Runners on Kubernetes | Bitbucket Cloud | Atlassian Support link to create runner in my EKS cluster but getting error "Invalid OAuth client credentials", 

I do not have permission to configure OAuth in Workspace level, so created repo level runner and used its configuration like all UUIDs and OAuth credentials in kustomized manifest and apply, but still that OAuth creds are not working and i am getting "Invalid OAuth client credentials" error.

When i was troubleshooting it and found that OAuth configuration need to be done at workspace level as per following link https://support.atlassian.com/bitbucket-cloud/kb/invalid-oauth-client-credentials-while-setting-up-autoscaler-for-runners-on-kubernetes/.

May be i could be wrong but i want you to clarify it.

Q: If someone do not have permission for workspace setting, then how can he use repo level runner in EKS?

because in my case i am facing the same.

 

0 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
TAGS
AUG Leaders

Atlassian Community Events