The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

pipeline - rpc error: failed to pull and unpack image on HARBOR private registry

Chengxiao Yang
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 1, 2024

We've used the harbor private registry for almost a year. Recently the pipeline suddenly reports the following error:

rpc error: code = Unknown desc = failed to pull and unpack image "hub.xxx.cloud/xxx/xxx:main": failed to resolve reference "hub.xxx.cloud/xxx/xxx:main": pulling from host hub.flexiv.cloud failed with status code [manifests main]: 403 Forbidden

We've checked the registry locally by pulling the images from the url. It works.

Is anyone else facing the same issue? How can I resolve this error?

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

3 votes
Answer accepted
Chengxiao Yang
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
January 1, 2024

It looks like the private registry is set up with restricted access from the public network.

DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events