The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

integration with jenkins via webhook getting access denies

Govind Vinjamuri
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
December 7, 2023

tried adding username:password to test in jenkins/bitbucket-webhooks 

 

but still getting access denied

 

any help is appreciated 

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Theodora Boudale
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
December 8, 2023

Hi Govind,

Where exactly do you see this Access denied error? Have you enabled history for the webhook on Bitbucket website and does this error show in the log for this webhook?

If so, could you perhaps share the following details?

  • the last two letters of the workspace id and repo name (or any other combination that help me identify the repo from the ones you have access to)
  • the date and time these events were triggered

I can then check our webhook logs of this repo for more details about the error you are seeing.

If you don't feel comfortable sharing that here, you can also create a ticket with the support team (which will be visible only to you and Atlassian staff) and share the repo details there. You can create a ticket via https://support.atlassian.com/contact/#/, in "What can we help you with?" select "Technical issues and bugs" and then Bitbucket Cloud as product. When you are asked to provide the workspace URL, please make sure you enter the URL of the workspace that is on a paid billing plan to proceed with ticket creation.

If you don't see the error in the webhook log of Bitbucket, can you please explain where you add the credentials and where exactly you see this error?

Kind regards,
Theodora

DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Product Admin
TAGS
AUG Leaders

Atlassian Community Events