The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

ftp-deploy -> mirror: Login failed

Kilian
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 29, 2021

Hey!

I try to upload files with pipe: atlassian/ftp-deploy:0.3.6 and i get the following error:

mirror: Login failed: 550 SSL/TLS required on the control channel

I appreciate any help!
Thanks!

2 answers

2 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Answer accepted
Kilian
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
April 30, 2021

Thank you @Gonchik Tsymzhitov 

It works now. My solution was lftp instead of ftp-deploy:

 


- step: name: Deploy
script:
- node -v
- npm install
- apt-get update
- apt-get install -y lftp - lftp -e "open XXX; user XXX XXX; mirror -X .* -X .*/ --reverse ./build/ ./; bye"
0 votes
Answer accepted
Gonchik Tsymzhitov
Community Champion
April 29, 2021

Hi! 

Based on the other resource, did you try param --insecure or is it possible to put into pipe?

TAGS
AUG Leaders

Atlassian Community Events