The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Getting fatal error: “certificate verification …” while trying to use ftp on bitbucket pipeline

waleed bin khalid
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 13, 2019

0

I've created a ci pipeline for my ReactJS project on bitbucket. Everything goes well till step 2 while pipeline tries to deploy the build on my Bluehost VPS. Here is log

INFO: Enabling debug mode.
INFO: Starting FTP deployment to werplay.com:public_html/jeeto/...
+ LFTP_DEBUG_ARGS=-vvv
+ run_pipe
+ info 'Starting FTP deployment to werplay.com:public_html/jeeto/...'
+ echo -e '\e[36mINFO: Starting FTP deployment to domain.com/path...\e[0m'
+ set +e
+ lftp -u 'username,password' -e 'mirror --delete-first -vvv -R / path' server-domain
mirror: Fatal error: Certificate verification: subjectAltName does not match ‘werplay.com’ (0F:4A:6E:B0:30:BE:B2:93:79:CB:4D:0F:A2:7B:2F:7E:54:71:13:C1)
+ set -e
+ STATUS=0
+ [[ 0 == \0 ]]
+ success 'Deployment finished.'
+ echo -e '\e[32m✔ Deployment finished.\e[0m'
+ exit 0
✔ Deployment finished.

I've already tried creating an lftp.conf file with set ssl:check-hostname false; but it didn't work.

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Alexander Zhukov
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
June 14, 2019

Hi @waleed bin khalid . This is weird. The certificate for your host looks valid. It looks like lftp fails to fetch this certificate for some reason. Are you able to connect with lftp you your server manually?

waleed bin khalid
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 14, 2019

@Alexander Zhukov Yes I'm able to connect with it using FileZilla 

TAGS
AUG Leaders

Atlassian Community Events