The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Canot run stash on virtual server

WHK
Contributor
July 10, 2016

I have a virtual server installed with kvm (virsh) on CentOS7 but does not start.

 

First run says"Required plugin com.atlassian.stash.ssh-plugin has failed to start", and found a solution here:

https://jira.atlassian.com/browse/BSERV-8345

 

I installed "haveged" using yum install, now reboot the machine but bbitbucket doesnot start, the port is opened, can connect from netcat using nc -v localhost 7990 but the server does not response, test with firefox, netcat, links but does not respond.

 

What happens?

 

The log says "canot connect to port 8006", this port is closed, what happen?

 

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Answer accepted
WHK
Contributor
July 10, 2016

A solution found:

https://confluence.atlassian.com/bitbucketserverkb/required-plugin-com-atlassian-stash-ssh-plugin-has-failed-to-start-is-displayed-when-accessing-the-bitbucket-server-web-interface-779171299.html

  1. Edit <Bitbucket_Installation_Directory>/bin/setenv.sh
  2. Find and replace: JVM_SUPPORT_RECOMMENDED_ARGS="-Djava.security.egd=file:/dev/./urandom"
  3. Reboot service "service atlbitbucket restart"

The problem is same as Google Compute Engine, booth using virtual instances.

It is a bug of installation script? not detect when the server is a dedicated o virtual instance for these changes.

TAGS
AUG Leaders

Atlassian Community Events