The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't setup SSH connection to a repo in Bitbucket server

heihachi88
October 31, 2016

I have installed Bitbucket server behind nginx. Everything is working except SSH connections to my repository. If i try: 

git clone ssh://git@domain.com:7999/wp/news.git

I am getting the following error:

Cloning into 'news'...
ssh: connect to host git.domain.com port 7999: Operation timed out
fatal: Could not read from remote repository.
Please make sure you have the correct access rights
and the repository exists.

I have successfully enabled SSH in the settings page: https://yadi.sk/i/Ru6Q4E09xvCiM

If i try to connect without mentioning port 7999 i am asked for a password, but none of them works. My Bitbucket server works behind nginx.

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

0 votes
Answer accepted
Jeff Thomas
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
November 1, 2016

Is port 7999 open on the server? You may have a firewall rule that prevents connections on that port. 

What do you get when you run the following?

ssh -p 7999 git@git.domain.com whoami 

heihachi88
November 1, 2016

I am getting timeout. But if i do that on a host machine i get permission denied (public key). So i've installed haproxy, but cannot set it up... god.. http://stackoverflow.com/questions/40361894/haproxy-config-for-bitbucket-server

Jeff Thomas
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
November 1, 2016

I just commented on the Stack Overflow question, try adding "mode tcp" to the front end. It seems to be defaulting to http.

TAGS
AUG Leaders

Atlassian Community Events