The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Bitbucket runner macos make pipeline faile after restart

Shin JS You
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 29, 2023

When I add new runner about macos, it works fine on bitbucket pipeline.

But after I restart runner. Pipeline will show system error.

After add new runner again, it works fine on bitbucket pipeline again.

Should I re-add a new runner after the original runner shut down every time?

1 answer

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

1 vote
Norbert Csupka
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
August 30, 2023

Hello there,

THank you for reaching out to Atlassian Support.

I suspect what happens here is that when you exit the Runners, it doesn't delete the temporarily files stored under /tmp/runner_id hence when you start the build after you restart the Runners, it fails

To resolve this, can I ask you to delete the /tmp/runner_id directory after you stopped the Runners and let us know if that makes any difference?

Tim L
June 21, 2024

I have this same problem. I can delete the /tmp/runner_id but the next time I run the pipeline that same tmp folder is there again and get's left behind again. What is causing the tmp file to stay and is there anything I can do so this does not happen? I can't even run two steps in my pipeline without removing that folder in between each step.

DEPLOYMENT TYPE
CLOUD
TAGS
AUG Leaders

Atlassian Community Events