The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Bitbucket Server is not starting after password change for the user for BitBucket database is SQL

Niyazi Ozturk
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 24, 2019

Hi All,

My problem started when the BitBucket server stopped after password expired in the database. I changed the pwd in the db and updated the bitbucket.properties file (the password part) at, Stopped the services.

C:\Atlassian\ApplicationData\Bitbucket\shared\bitbucket.properties

jdbc.driver=com.microsoft.sqlserver.jdbc.SQLServerDriver
jdbc.url=jdbc:sqlserver://<my_local_ip>:1435;databaseName=Bitbucket;
jdbc.user=<user_name_for_bitbucket>
jdbc.password=<my_new_pwd>

Started the BitBucket services again... since then almost 5 hours of no luck..

I am sure that it is the connection issue. Becuase when I run the browser to connect the bitbucket server, It says Spring starts, Migrating Home etc. and after that it stops because of the connection issue. Same configuration exists on my laptop and runs ok. But not on my work server. It seems that HazelCast is not starting. 

Error Message: 

  • A fatal error has occurred

    The following problem occurred, which prevents Atlassian Bitbucket from starting:

    • The database, as currently configured, is not accessible. 
      Login failed for user 'bitbucket'. ClientConnectionId:e578827a-f93

0 answers

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

TAGS
AUG Leaders

Atlassian Community Events