I had followed these instructions,
And everything seemed to be ok. but,after few days, when a user tries to sign into bitbucket, e is answered "The remote authentication server is not available. Please try again later.". However the server is running because one can log into JIRA.
Community moderators have prevented the ability to post new answers.
Hi. I solved it and will paste here the info for helping others.
The last post (from Benjamin Brodie, on June 16 2014) of this thread, https://answers.atlassian.com/questions/221159, more or less describes what happened in my server and the solution. I'll just add a bit of info to make it more clear one thing that was not clear to me:
1 - Disable and then Remove the JIRA Server directory. In Bitbucket administration > Accounts > User directory.
2 - Click "Add Directory" and re-enter all of the necessary details.
3 - I don't know if it has helped anything but previous to this I also deleted the connection between Bitbucket and JIRA and then, reconnected (as per https://confluence.atlassian.com/bitbucketserver/connecting-bitbucket-server-to-jira-for-user-management-776640400.html).
So now it was solved the JIRA User server for bitbucket. I will now monitor in the following days and check to see if this stabilized my JIRA and Bitbucket blocking access to users with ERR_CONECTION REFUSED.
Cheers all
Oh. Yes.
Actually I think this might be the problem: In My setup, my JIRA port is not the :8080 but in the logs, I see that one of the errors is:
Caused by: org.apache.http.conn.HttpHostConnectException: Connect to site:com:8080 [site.com/xx.xx.xx.xx] failed: Connection refused.
Error chain:
'JIRA User Directory' is not functional during authentication of 'user'. Skipped.....
Caused by: com.atlassian.crowd.exception.runtime.CommunicationException: null....
Caused by: org.apache.http.conn.HttpHostConnectException: Connect to site:com:8080 [site.com/xx.xx.xx.xx] failed: Connection refused.
Caused by: java.net.ConnectException: Connection refused
I dunno if it is related or might help to diagnose but perhaps this is causing Bitbucket and JIRA to kind of block access - from time to time, JIRA or Bitbucket start to refuse connections and I need to restart the services (as described in this my other post:https://answers.atlassian.com/questions/39977369)
Do you know where I can set properly the port for apache?
Thanks in advance
You must be a registered user to add a comment. If you've already registered, sign in. Otherwise, register and sign in.
Hey Dinis,
Do you see any errors in the logs? Log files can be found at <HOME_FOLDER>/logs/atlassian-bitbucket.log
You must be a registered user to add a comment. If you've already registered, sign in. Otherwise, register and sign in.
Community moderators have prevented the ability to post new answers.
You must be a registered user to add a comment. If you've already registered, sign in. Otherwise, register and sign in.