The Atlassian Community Forums are currently in read-only mode. We will be relaunching on a new platform on September 22 (read more here). We apologize for the extended downtime. For concerns or questions, please email communitymanagers@atlassian.com. See you on the other side, on the new Atlassian Community Forums! :)

×

Forums

Articles
Create
cancel
Showing results for 
Search instead for 
Did you mean: 

Upgrading to Bamboo 9.3.1 from 8.0.13 gives useSSL errors

Zed Saeed
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 3, 2023

we have hit a snag whilst upgrading from our last working version of 8.0.13 to 9.3.1.

Firstly we had to upgrade from java 1.8.0 -> Java 11

now when we try and logon to bamboo we are met with a refused connection.

The Log is showing:-

Wed Aug 02 10:42:35 CEST 2023 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification. my connector property has useSSL=false in, but still faililng

However our bamboo.cfg.xml has this property already in place and it doesn't seem to be taking:-

(N.B. exact hostname and port ommitted for obvious reasons)


 <property name="bamboo.jms.broker.client.uri">failover:(tcp://hostname.example.com:NNNNN?wireFormat.maxInactivityDuration=300000)?maxReconnectAttempts=10&amp;initialReconnectDelay=15000&amp;useSSL=false&amp;sslMode=PREFERRED&amp;</property>

any ideas/pointers etc on how we progress and move forward with this at all please?

1 answer

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

3 votes
Answer accepted
Charlie Misonne
Community Champion
August 3, 2023

Hi @Zed Saeed

The property you shared in your questions is the broker URI while the error is related to MySQL. Your database is MySQL right?

What is your hibernate.connection.url property?
You'll need to add useSSL=false in there assuming your MySQL does not require SSL. Use true if if it does require it of course.

Here is an example I fetched from another question. You might not need all those paremeters, it depends on your setup but useSSL=false is in there.

Note how the ampersands (&) are encoded as &amp;

<property name="hibernate.connection.url">jdbc:mysql://192.168.xx.yy/bamboo?autoReconnect=true&amp;useUnicode=true&amp;useSSL=false&amp;characterEncoding=utf8&amp;sessionVariables=storage_engine=InnoDB</property>
Zed Saeed
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 3, 2023

@Charlie Misonne - thank you, that has done the trick, so kudos to you, being a complete newbie to these products, i think there was some ( obvious ) confusion between hibernate.connection.url and bamboo.jms.broker.client.uri, which showed, cheers.

Like • Eduardo Alvarenga likes this
Charlie Misonne
Community Champion
August 3, 2023

glad I could hep!

Like • # people like this
TAGS
AUG Leaders

Atlassian Community Events