Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Trello Cards Disappeared!

Ok  (sad face), this is not a good start.  I have no idea what I clicked for this to happen.

I have four headings that all show up, except the cards are hidden - I hope!

It says 6 cards or 10 cards, etc. but where are they?

My entire screen background changed as well.  The last thing I did was add a picture to a card.  I guess I clicked the wrong button the second time I added a photo.  The first time worked very well.  

Does anyone know how to get my cards to show again?


Friday night blues!

1 comment


Log in or Sign up to comment
Hamza Chundrigar
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Nov 11, 2022

Hi Natasha,

Can you confirm if you don't have a filter applied to your board (this may be why those 6 cards are hidden)?

What browser are you using? For instance, if you're using Chrome — are there any extensions that might be interfering with your Trello Board? Can you try logging into your Trello from an incognito window and see if the situation persists?

Have you tried reproducing this situation using a separate browser (i.e. Firefox, Edge, etc). It's possible that you might need to update your browser.




Thanks for responding!  I am not sure where the filter could be applied.  I am using Edge as my browser.  I will check on the filter and let you know.

You guys are the best!  I went in Incognito and there are all my cards in tact.  So, now why is that happening?  Do I need to remain incognito?

AUG Leaders

Atlassian Community Events