Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Confluence Replacing a failed plugin with an older version.

Hi all,

I am in an urgent need here.  Atlassian hasn't gotten back to me, and I have installed Team calendars 5.2.11 and it simply does not enable.  This is a very highly used tool needed daily by my users.   I went and got 5.2.10 but every time I upload it, it does not replace 5.2.11?!?   Do I have to uninstall 5.2.11 first?   Will any data be lost if I do that?  (We are using Confluence 5.7.3)

As for 5.2.11 the log files states:

2015-05-19 08:09:13,974 ERROR [ThreadPoolAsyncTaskExecutor::Thread 45] [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] fail Unable to create application context for [com.atlassian.confluence.extra.team-calendars], unsatisfied dependencies: none
-- referer: https://cww-us.comsol.com/confluence/plugins/servlet/upm | url: /confluence/rest/plugins/1.0/com.atlassian.confluence.extra.team-calendars-key | userName: robertn
org.springframework.beans.factory.parsing.BeanDefinitionParsingException: Configuration problem: Unable to locate Spring NamespaceHandler for XML schema namespace [http://www.springframework.org/schema/context]

Thanks in advance,

Robert

1 answer

1 accepted

1 vote
Answer accepted


Hi Robert,

Yes you need to uninstall. Data will not be lost, however, you can make a back up of the following tables

 

`AO_950DC3_TC_CUSTOM_EV_TYPES`, `AO_950DC3_TC_DISABLE_EV_TYPES`, `AO_950DC3_TC_EVENTS`, `AO_950DC3_TC_EVENTS_EXCL`, `AO_950DC3_TC_EVENTS_INVITEES`, `AO_950DC3_TC_JIRA_REMI_EVENTS`, `AO_950DC3_TC_REMINDER_SETTINGS`, `AO_950DC3_TC_REMINDER_USERS`, `AO_950DC3_TC_SUBCALS`, `AO_950DC3_TC_SUBCALS_PRIV_GRP`, `AO_950DC3_TC_SUBCALS_PRIV_USR`, `AO_950DC3_TC_SUBCALS_PROPS`

 

Regards

Nelson

Thanks I did and it did go back to 5.2.10, but that now does not enable. Oh well, hopefully Atlassian will get back with me soon.

You can also try to delete plugin cache; however, this requires to restart Confluence. https://confluence.atlassian.com/display/CONFKB/How+to+clear+Confluence+plugins+cache

Great idea. I have scheduled a reboot for noon and when I do that I will remove all the caches...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Opsgenie

Opsgenie and Amazon team up to launch new DevOps Guru integration - now available!

We’re proud to announce that our integration with Amazon DevOps Guru is now live. The Amazon and Opsgenie product teams have worked together to build a deep integration between Opsgenie and the new...

280 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you