Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,296,563
Community Members
 
Community Events
165
Community Groups

unable to open web browser - ERROR

Hi

I am trying to sync my local repository to remote but I get this error. My browser (firefox) is set as default in windows. I get this error when I try to view repository online or when i hit the remote button in the task bar. sourcetreerror2.png

I assume this is why my files in the online repository are really old? I need to get this project onto MacintheCloud so I can publish ios version of project so would really appreciate some help in getting this sorted.

How do i fix?

thanks

2 answers

I found this on another post.  Seems to work:

  • In Sourcetree, click on the "Settings" button, located on the top-right of the screen
  • On the window that opens, in the "Remotes" tab, select your remote and click "Edit"
  • If all the information is correct in that window (it was in my case), simply click "OK"
  • Click "OK" again to close the "Repository Settings" window

That fixed it for me. It seems to me that re-setting the URL of the repository to the same address is what does the trick. I hope it works for you as well.

This worked for me too.  Geez, dumb software...

Like # people like this

In a similar vein, I found that I had to delete and then recreate the 'Remote repository path' settings to make the error go away (with no changes made).

worked, amazing. thanks 

When you clone a project you can choose among 2 protocols: either using git over ssh, or https. I always use git, because I can just use an ssh key and forget about passwords management.

I just tested with a project cloned with https, and the browser is opened correctly. On the other hand, when using git I get the same error as lz7cjc. Looking at the log messages I cannot believe that they are really trying to open a browser at the URL git@gitlab.com:repository/path.git without even checking how the project was configured, and if that string is a valid URL or not.

My Sourcetree still has this problem and I have the latest version (3.4.4).  Please fix this.

"Unable to open your web browser to 'git@git-server.domain.org:repo/project.git' ", it also incorrectly attributes the problem to not having a default web browser (I do have a default web browser == Firefox 78.10.1ESR)

Note I'm obscuring the actual url, but the point is that it's showing it in "git@host.domain:repository/project.git"  URL format.  I do not want to set my git clone urls to https format, I want 'git' (ssh) format.  Sourcetree should really manage a separate https repo link for the Remote button to use with the browser.

Like # people like this

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,378 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you