Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,360,098
Community Members
 
Community Events
168
Community Groups

unable to add account in sourcetree

Edited

Hi 

When I try to add my bitbucket account to Sourcetree via Tools > Options > Authentication > Add.  I fill in my user credentials and I get the following error:

Failed to get user details for user [dominique_denie]. You do not have the permission to access the URL 'https://api.bitbucket.org/2.0/user/'. The request returned with status code 'Unauthorized'.

I have tried using both SSH or HTTPS, but to no avail. I am working behind a proxySourctree_error.png

5 answers

Same issue and I am using Chrome instead of IE. Any solution?

have the same issue here

Any solution for this? having the same issue....

Same happening to me here. Any idea ?

0 votes
Ana Retamal Atlassian Team Oct 03, 2018

Hi Dominique, welcome to the Community!

Are you entering your username or your email address? When you get the prompt to enter your credentials you'll need to enter your email address as the username is no longer used to log in into Bitbucket Cloud.

Also, if you're on Windows, make sure Internet Explorer is updated to the latest version as Sourcetree relies on it for the authentication and it can cause problems otherwise.

If you're still having issues after trying that please let us know, so we can continue helping you.

Best regards,

Ana

Hi Ana, 

I tried with both my username and my email but both failed. I am currently using IE 11.

Best regards,

Dominique

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

78,751 views 134 29
Read article

Atlassian Community Events