sslv3 alert handshake failure

kiddoware December 1, 2018

Hi,

I suddenly started getting error when doing a pull from remote repo: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Everything was working well till last night and nothing has been changed. 

Source Tree version: 2.4.80 running on windows 10

5 answers

1 accepted

2 votes
Answer accepted
kiddoware December 3, 2018

I got it resolve, by uninstalling sourcetree and git also and doing a fresh install of sourcetree with integrated GIT. Please give it a try. 

Dave Rushton December 3, 2018

just tried it and am still getting the same error. Thanks for putting up your solution though!

rasxod December 3, 2018

это не вариант у меня 200 репозиториев

Like Senthilkumar S likes this
21 votes
rasxod December 3, 2018

есть решение

надо обновить встроенный GIT

2018-12-03_23-21-00.png

rgyalrongskad December 3, 2018

Спасибо большое, все решилось!

Dave Rushton December 3, 2018

Update Embedded Git worked for me. I didn't understand any of the text but I DID understand the image. Thanks!

Like # people like this

Thanks ! It Worked

Sergey Gussak
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
December 4, 2018

That worked, thanks! I used system Git, which was v 1.x, and switching to Embedded Git, which is 2.x, and updating it helped. It looks like Atlassian changed something in Bit Bucket over the weekend, and it rendered it incompatible with the old Git versions. Probably, upgrading system Git would help too.

Like Pradeep Paneru likes this
wtarte January 10, 2019

Worked here too.  Thanks a ton

gold0206 January 28, 2019

Awesome. That worked.

Thanks

eldersilva March 10, 2019

Thanks for the solution, solved my problem.

uoc1691 April 8, 2019

This worked. Thanks!

djwendel April 30, 2019

Same here - thank you!

Tigran Minasyan June 4, 2019

Thanks! This worked. 

Anuj Mishra August 5, 2021

Perfect Answer, works like a charm, I additionally also updated the mercurial version as well now all authentication is working.

0 votes
Pradeep Paneru December 13, 2018

My similar issue was resolved by re-installing GIT. Due to the system limitation, I had to install GIT version 2.10.0.

0 votes
KarthikVeera December 4, 2018

I managed to fix my issue by

 

 

A. Go to "Tools > Options > Git" and selecting "Use System Git" instead of "Use Embedded Git".

 

Mohammad Nur Uddin May 6, 2019

how can i go to "Tools" ?

Like Akhil Aggarwal likes this
0 votes
rasxod December 2, 2018

win 7 

I have the same error

fatal: unable to access 'https://***@bitbucket.org/***/***.git/': error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Dave Rushton December 2, 2018

I also have the same error. VERY FRUSTRATING

Dave Rushton December 3, 2018

I have used SourceTree for the past 3 - 4 years and had no issues until now. I uninstalled and reinstalled both Git and SourceTree and I still get the same error

Like FinixChang likes this
studiospec June 13, 2019

Appreciated!

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events