sslv3 alert handshake error

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
fatal: unable to access 'https://git.abc.com/iis/App-Server.git/': error:14077410:SSL routines:SL23_GET_SERVER_HELLO:sslv3 alert handshake failure
Completed with errors with errors, see above.

 

i tried change the security protocols  TLS 1.1 and 1.2 and turning on ssl3 and then off but nothing yet.

runing version 2.1.10.0 under windows 2012r2

 

thanks

 

3 answers

This widget could not be displayed.

Hi! That could be related to this OpenSSL bug. They mentioned the bug was introduced with OpenSSL v1+, can you check if that's the version you have, go back to a previous one and see if the error disappears? This was documented at Git clone fails with SSL routines.

If you're still having issues, and for troubleshooting purposes, can you try to do the operations using the terminal (instead of SourceTree) and let us know if you're also getting that error?

Best regards,

Ana

Hi!
This morning I "stumbled" into the same problem, that i couldn't connect to our repository due to that damn SSL handshake failure.

A quick internet search has led me to this page, but I was glad to fix the issue as it also occurred after re-installing Sourcetree and trying to connect to our repository via the terminal.

I installed a more recent version of GIT (2.14.1) and it worked again.

Best Regards,
Benny

This widget could not be displayed.

IF i try to "open in terminal" option it opens an cmd and then closes it. im unable to catch any errors.

the ssleay32.dll version is 1.0.2d

the libeay32.dll version is 1.0.2d

 

they are both under the AppData\Local\Atlassian\SourceTree\git_local\mingw32\bin folder.

if I remove / rename the entire install of atlassian and then do a fresh install should it not install the lastest version of these?

leaving sourcetree...to bad it was nice while it lasted.

all the same information to connect to my git server works under VS code.

This widget could not be displayed.

I was able to solve it by running

git config --list --show-origin

and then seeing that I had a line:

 file:c:/Users/user/.gitconfig     http.sslversion=sslv3

I edited the file, c:/Users/user/.gitconfig, and deleted the line [http] and the line sslversion=sslv3 and that fixed it for me. Reinstalling git and source tree do not remove the config file, so they don't help.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

874 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you