Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,079
Community Members
 
Community Events
165
Community Groups

ssh-agent failed with code -1 on load on SourceTree

Hi everyone,

Lately I've been having tons of issues with SourceTree and this seems to be the last one. 

Out of the blue, I start getting "ssh-agent failed with code -1" when I start SourceTree.

Needless to say, the service is up and running.

I start digging and I found this thread https://community.atlassian.com/t5/Sourcetree-questions/Error-on-load-ssh-agent-failed-with-code-1/qaq-p/1404992 which is very similar to the problem I have. Tried every single solution presented there but nothing worked.

If I tried to update embedded git, I get access denied. If I try to use system git, I get the same error. Trying to manually upgrade local git has no effect..

If I run SourceTree as administrator, I don't get the error but I am forced to enter my pass key used for open ssh key which is incredibly annoying. Not to mention that I find it unwise to run anything as admin unless you really have to. And this is not the case.

This is incredibly frustrating. Since they made those changes to the authentication system , starting March 1st, I've spent more time trying to fix SorceTree issues then do my actual job.

Any ideas?

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,845 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you