It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

sourcetree, sslv3 alert handshake failure

When trying to push my most recent commit, I got the message:

git -c diff.mnemonicprefix=false -c core.quotepath=false push -v origin master:master
Pushing to https://rgyalrongskad@bitbucket.org/rgyalrongskad/japhug.git
fatal: unable to access 'https://rgyalrongskad@bitbucket.org/rgyalrongskad/japhug.git/': error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

I also get this error when typing "git push" or "git pull" on the terminal. I have tried to re-install git to obtain the latest version, but to no avail. Is there any way to solve this problem?

 

 

3 answers

2 accepted

2 votes
Answer accepted

I managed to fix my issue by

A. Go to "Tools > Options > Git" and selecting "Use System Git" instead of "Use Embedded Git".

Where you managed this option? Which Program ?

Like FinixChang likes this

Thanks! It works for me.

Thankyou!! Ver much :D It work for me 

0 votes
Answer accepted

I am also getting the above issue.

I also have the same error. PLEASE FIX IT

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you