Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

sourcetree mac stuck at "registration complete"

John Little April 25, 2018

I installed the mac version, which forces you to login with an atlassian account. So I created a dummy one on their website, and entered these details. Then it says "Registration complete!" and it says "you are logged in with xxxx" and a "continue" button.

However, the continue button does not work, pressing it has no effect.  I am stuck at this point. On the left, it shows the next step as "atlassian account".

I just want to use source tree with github.

4 answers

1 vote
Min K
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 14, 2018

get exact same issue. any advise?

PH
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 14, 2018

This works for me:

When you get stuck, close the window with the 'X' and choose "Quit" - Sourcetree quits.

Restart Sourcetree, which will open the set up window again with the check boxes for the customer agreement and send data to Atlassian. Ignore those and close the window again with the 'X' and choose "Quit" - the window disappears and Sourcetree starts normally.

You have to do this every time you restart Sourcetree.

A proper fix would be better, please Atlassian!

Roger
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 11, 2018

@PH That totally just unstuck me. How did you ever think of that. Must have come from true gritty frustration. Super appreciate your sharing. Thank you!

Julien Coppi
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 22, 2018

Same issue (with all version 2.7.x I tried) and same fix. Greatly appreciated!

0 votes
Huailei
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 8, 2018

I have an ad blocker which block request that contain "analytics". Sourcetree trying to request "http://btf-analytics.s3.amazonaws.com/config/uid.onewayhash" and get blocked, that's reason you cannot continue to the next step.

MythJuha
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
October 14, 2019

Very annoying as this is blocked by my corporate firewall

0 votes
David Buser October 8, 2018

I had the same problem. But I'm using Pi-Hole to block ads on my network. Disabling Pi-Hole took care of the problem.

I'm curious what URL SourceTree is trying to access. I didn't think to check that. I'm guessing it's Google Analytics or something.

0 votes
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
April 26, 2018

Hi John, can you send us a screenshot so we can see exactly where are you stuck? Can you also let us know if you've tried already restarting the application?

Lastly, please have a look at the logs in case they give any useful information for us. On Mac, the SourceTree logs can be found by opening the Console application (Applications >> Utilities >> Console) and searching for entries related to "SourceTree".

Let us know!

Ana

Andreas Åhman
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 19, 2018

I have the exact same issue.

Nothing in the Console.

sourcetree.png

macropin
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
June 25, 2018

I also have the exact same issue. Sourcetree version 2.7.6a.

Reverting to 2.6.3a works.

PH
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 5, 2018

Exactly the same for me, I do get a log in the console though:

2018-07-05 23:18:21 +0000 (e) Error while recording wizard event. Description - An SSL error has occurred and a secure connection to the server cannot be made., Reason - (null)

That's Sourcetree 2.7.6a on macOS 10.13.5 (High Sierra).

This doesn't really fill me with confidence for using Sourcetree for something as critical as source version control if it can't even get past the on-boarding, especially as it's over 2 months since this issue was first reported.

Min K
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
July 14, 2018

get exact same issue. please advise

jaredwolff
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
September 6, 2018

I deleted the Application Data folder for the app and seems ok now. You can back yours up just to be sure. Fixed the install and was able to proceed to the next step.

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events