Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

sourcetree keeps crashing after upgrade to 4.1.1

Phillip June 17, 2021

I upgraded the source to latest version 4.1.1 but it keeps crashing whenever I click any repo after that. How can I fix it?

Process:               Sourcetree [9208]
Path:                  /Applications/Sourcetree.app/Contents/MacOS/Sourcetree
Identifier:            com.torusknot.SourceTreeNotMAS
Version:               4.1.1 (237)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Sourcetree [9208]
User ID:               501

Date/Time:             2021-06-16 12:30:58.563 -0400
OS Version:            macOS 11.4 (20F71)
Report Version:        12
Anonymous UUID:        D1F6D388-FE59-1547-31C8-BEF723D91654


Time Awake Since Boot: 230000 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [9208]

VM Regions Near 0:
--> 
    __TEXT                      10bc16000-10bf0e000    [ 3040K] r-x/r-x SM=COW  /Applications/Sourcetree.app/Contents/MacOS/Sourcetree

Application Specific Information:
Performing @selector(localOutlineDoubleClick:) from sender STRepoBrowserBookmarkOutlineView 0x7fa54d044600

Any help is greatly appreciated

2 answers

0 votes
hkalan July 15, 2021

Same here. Using Sourcetree v4.1.2 and macOS Catalina (10.15)

0 votes
jonathanpglick June 22, 2021

I'm seeing the same thing. It was working fine until last week. Now I can open Sourcetree (v4.1.2) but once I try to open a local git repo it hangs, becomes unresponsive, and I have to force quit.

I'm on macOS Big Sur (11.4) with the Apple M1 chip.

I tried uninstalling and installing the last few versions and it didn't work. Restarting my computer gets it working for a while but I've had to restart multiple times a day now.

757007049 July 19, 2021

I reinstalled the old version, so far there are no problems

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events