restore older version of SourceTree

Hi.

I just updated my MAC SourceTree to v1.9.0 and I really regreat. I want to go back to the previous version.

How can I do that while preserving all the repositories info already registered with it?

18 answers

1 accepted

I find the new commit view, or "experience" as Atlassian puts it, to be more confusing than just using the command line. For that reason, I've uninstalled Source Tree. Hopefully they'll bring back the old version, but I won't hold my breath.

Check out the following file - it contains download links to all previous versions.  I was able to roll back from the very unstable 1.8.1 release to 1.7.0.

https://www.sourcetreeapp.com/update/windowsupdates.txt

 

What is the process for downgrading on Windows? I downloaded the 1.7 release but when I run the installer it tells me that there is a newer version already installed. Very sorry that I bothered to upgrade at this point.

Thanks!

Uninstall the new version in Programs and Features (Windows 8).  Then install old version.

https://downloads.atlassian.com/software/sourcetree/windows/SourceTreeSetup_1.7.0.36739.exe

 

@Shane Triem: I can't get that one to work:

"The requested URL /software/sourcetree/windows/SourceTreeSetup_1.7.0.36739.exe was not found on this server."

Weird.  They must have taken it down.

I've only been using version 1.8.2 for 30 mins and I have already decided to downgrade. Highly recommended to wait until they fix some more bugs. This version is rubbish.

I don't even get the joy of trying out the new version.  I've been forced to downgrade as I can't even do the account verification stage.  No, didn't forget my password, I'm getting this:

 

Invalid CSRF token found in form body

Thanks @Mikkel Riise Lund, that one works.

1.8 is so FUGLY... I can't believe they went live with it.

Thank you so much! I've honestly tried using 1.8.2 but it's not just ugly, it's also buggy.

I also found that SourceTreeSetup_1.7.0.32509.exe was the only 1.7 that I could access.

Atlassian, is there really no actual web page for accessing older versions?

 

I appreciate the text file list provided by @Shane Triem of older versions (that may have entries that are no longer available), but it seems a kludgy work around to the lack of an actual web page provided by Atlassian that gives clear access to the available older versions.

p.s. Whether Atlassian provides a suitable web page or not, thank you @Shane Triem for providing the link to the text file that you found.

After uninstalling 1.8 and installing 1.7.0.32509, I did notice that Check For Updates did claim that the two newer 1.7.0.* updates were available (even though I could not retrieve either of them directly at their supposed URL).

I did not try to upgrade to either of them, so I don't know if the upgrade would have succeeded.  However, since their changes seemed to be primarily about adding extra internal logging, it doesn't seem that there is a strong reason in favor of the 1.7.0 versions newer than 32509.

Interestingly, I just received a survey from Atlassian regarding SourceTree.  Yes, I took the time to fill it out.  My 3 biggest improvement suggestions:

  1. Quality - I went into detail - enough said
  2. An easy means to downgrade (page on site with links to all previous release downloads)
  3. Get input from community BEFORE making such drastic changes to the UI (refer to this page:  https://answers.atlassian.com/questions/36182163)

Now that Atlassian is a publicly traded company, it is important they listen to their users.

gosh I got the old version back! Thank you for the Link!

In case someone gets an error about broken uninstall wizzard when trying to uninstall the new version: Use the setup file from the new version. You can choose install/repair/delete their.

Thank you so much for these links! Managed to downgrade to 1.7 from the entirely useless 1.8 version.

 

I got stuck (went back to 2.1 on Mac) anything after that was really not great. I am too nervous to upgrade it again.

2.2 and 2.3 were not great updates.

Just received notification of a security vulnerability "that exists in SourceTree for Mac starting with 1.4.0 but before 2.5.1 and SourceTree for Windows starting with 0.8.4b but before 2.0.20.1."

 

Hopefully version 2.5.1 works well enough for you because anything earlier than that is very unsafe.  This is considered "a critical security vulnerability", so I would consider that it supersedes other considerations.

Details here.

For Windows downgrade use this link:

http://downloads.atlassian.com/software/sourcetree/windows/SourceTreeSetup_1.5.2.exe

The new file view is completely broken in 1.6.3

sweet jesus thank you so much. i was about ready to uninstall this POS. the old one is way, way better.

Thank you! This new 1.6.x is too buggy for me

Yes, thanks for this. 1.6.x is a usability disaster.

Thank you! The new UI is terrible :/

Have you tried 1.7.0.32509?  See the answer above by @Shane Triem and the comments to that answer.  Is there any reason to prefer 1.5.2 over 1.7.0.32509?

At the time of me writing this post 1.6.x was only available and pretty broken.

Since then, our company switched to Macs, so I cannot weigh in on 1.7.x  version.

 

I experienced also a lot of trouble after upgrading from a good version (1.7.0.32509) towards the 1.8.x version

the biggest issue (for me) was the complete f*-up in git flow, i've lost an hour getting it up and running again.
(used a workaround via command line for getting my work done and let the program wait until next day)

Thanks to the link https://www.sourcetreeapp.com/update/windowsupdates.txt from Shane Triem

i reverted by uninstalling the 1.8.x version and reinstalling 1.7.0.
i was lucky when i saw my repo config was still there and git flow was running as a charm again.

I'll stick to this version for a looonng time now.

Thank you so much for that link. I have gone back to 1.7 as well. Apart from looking awful, 1.8 is full of bugs. I guess I won't upgrade until 1.9.

I just "solved" it. I was able to get the previous version (1.8.2) from the link below and install it over the v1.9. So, I am now with the 1.8.2 and didn't not lose my repositories entries (which I think would have happened if I uninstalled it).

http://downloads.atlassian.com/software/sourcetree/SourceTree_1.8.1.dmg

after upgrading from 1.7 towards 1.8 nothing works well. Fail always when try to start new feature. Autofocus each xx second to "file status" tab and more a lot problems. I have come back to 1.7 and works like a charm.

BTW, if you install through the App Store you can still get v.1.5.6 - then just disable updates. It's not a long-term solution, but it'll work for now.

Just a "me too", the new view is a definite step backwards, much harder to scan over and see what's going on.

The new view I can get used to, but what I can't get used to is;

  1. No context-menu-item for commit
  2. The checboxes activate/deactivate staging of the files, the interface is a bit slow there and I get a lot of miss-clicks when I try to work too fast
  3. (most important) SourceTree 1.9.0 seems to freeze often during a push (1 in 5 pushes lock up ST and it needs a Force Quit)

Needless to say, I reverted to 1.8.1.

Thank you, though, Atlassian for continuing development, but I'll wait for 1.9.3 or higher until I try again.

+1 on your number2. This is making me downgrade again

Same here. The new commit view is terrible.

Same here. I can't get used to the new view.

All your complaints and more have been hashed out in detail on this other question. Instead of continuing to complain to the community (most of us have no influence over SourceTree development), please go to the bug reports in that post and vote.

You can simply reduce the version numbers by changing the url.

Try: http://downloads.atlassian.com/software/sourcetree/SourceTree_1.8.0.dmg

 

Same here, having issues with commits & merges

I'm still using version 1.7.0 - I used the link below (Shane Triem) so that I can bypass the confusion of the later versions.

version 1.9 does not like powershell. Even with the proper encoding and re-encoding to UTF-8.

The preview pane does not display powershell files which is the only reason why I am using soucetree
I reverted to 1.7 which is compatible with windows 10. The new interface did get some time to get used too but until it handles powershell files I will stay on 1.7

@DJ Torres - That's a very specific problem. Instead of commenting on a 2-year-old question, it might be more effective to submit a bug report to jira.atlassian.com.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

794 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you