Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

repo , local side having problem pushing to server side

Hi , I'm having problem with pushing my commits to server


here's the message


git -c diff.mnemonicprefix=false -c core.quotepath=false push -v --tags origin DevelopmentBranch:DevelopmentBranch
POST git-receive-pack (18954 bytes)
remote: Repository is in read only mode (over 2 GB size limit).


I've tried to search out the solution but they say that the best way to solve this is to ask for  support , and I tried to call git gc locally but no luck on this command

Please help me out!

2 answers

1 vote
Ana Retamal
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
Nov 06, 2018

Hi, welcome to the Atlassian Community!

I can see from the message you included that you reached 2GB in your repository, that's a hard limited established by Bitbucket Cloud and it's documented at What kind of limits do you have?. To fix that, you'll need to reduce the size of your local repo to under 2GB and then force push it to Bitbucket Cloud, you can find the steps at Reduce repository size.

Let us know if you need any further assistance!

Kind regards,


Hi Ana , last time I asked this question , I did nothing but after an hour I can push successfully . But this time I've encountered the same situation again and I tried to follow the link you've gave me , but still not working , I've tried 

git reset --hard HEAD~4

, the force push worked on that current commit,  but pushing the local commits after that didn't work out , can you help me  run a  git gc on the server for me please?



FIXED after removing "Tags" on repo...

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events