Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,659
Community Members
 
Community Events
176
Community Groups

re-enable warning for empty commits

By default, when you try do a commit with an empty commit message, you get popup to warn you. This popup has a checkbox "don't warn me again"

For a specific use case I needed to do a lot of commits where adding a commit message was unnecessary, so I checked the checkbox - expecting I could re-enable the warning in the settings later. However, I can't find this option anywhere.

How can I re-enable the warning for empty commits?

2 answers

Is there any ability to ability add this warning in version 3.4.7 of SourceTree? It seems that the configuration option mentioned above is no longer present.

0 votes

Hi Jaron! The way to re-enable that pop up depends on whic OS are you using:

- In Windows, edit the %localappdata%/Atlassian/SourceTree.exe_url_{hash}/{version}/user.config and change

<setting name="SuppressWarningOnEmptyCommit" serializeAs="String">

    <value>True</value>

</setting>

to

<setting name="SuppressWarningOnEmptyCommit" serializeAs="String">

    <value>False</value>

</setting>

- In Mac, type the following in your terminal

defaults write com.TorusKnot.SourceTreeNotMAS suppressWarnOnEmptyCommit NO

and press 'Enter'.

Cheers :)

Ana

Yay, it worked! Thanks Ana.

Ana Retamal Atlassian Team Jun 23, 2017

Glad to hear that, Jaron. Have a good day!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events