"launch external merge tool" is disabled on the "Resolve conflicts" menu

I have tried every available config for external merge tools, beyond compare is my preference, but whatever I try the menu to launch it is disabled. I've tried each option on the preconfigured dropdown and a custom path direct to beyond compare. What can I do to fix this? I can't fix my conflicts!

 

2015-06-02 19_47_28-SourceTree.png 

4 answers

This widget could not be displayed.

if you select  a file that has code conflict , this option will be enabled. in your case (from screenshot) I believe that you don't have a conflict , that is why it is disabled.

This is correct. Try selecting "External Diff" (It's above "Add").

External diff does work but I can't resolve conflicts with it. What else flags a file as conflicted if not the conflict comments that the merging added to my files?

This widget could not be displayed.

I tried the same again and here is a larger screenshot:-

 

2015-06-03 13_21_19-SourceTree.png

 

I recognise that the file icon show "modified" not "conflict", but look at the change log on the right. 

What does "<<<<< HEAD" indicate ? is that a conflict or not?

Yeah, there was a conflict, but for some reason Git doesn't recognize it as one. Git should set an internal flag whenever the conflict markers are written to the file, but it definitely does not scan the file contents for conflict markers. Try choosing the "Mark Unresolved" option, or maybe "Restart Merge".

Had tried "restart merge" with same result. Have not tried "mark unresolved" yet. How does sourcetree determine a conflict? It must be something other than "<<<< HEAD" etc.

Git is responsible for flagging conflicts. SourceTree gets that information from Git. I don't know how Git makes the determination, but it is certainly not by checking file contents (that would be very inefficient, and wouldn't work for binary files).

This widget could not be displayed.

My guess is that one of the previous commit had a merge and it was not resolved correctly either by you or someone else.  so the markers was committed to git. you may open that file in a text editor and manually remove those markers and duplicate code  .

No sorry, the conflict lines where created in that merge. This is apparent in the screenshot by virtue of them being coloured green in the log view.

if that was caused in the merge, revert it and redo the merge again or fix it manually. did you resolve conflict after merge, that must be unsuccessful.

This widget could not be displayed.

I had the same problem.  I had to mark the files unresolved to get the "Launch External Merge Tool" menu item to be enabled.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

879 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you