"Use existing account" does not work with latest SourceTree

When I click "Use existing account" it just hangs with the latest version of SourceTree. I can no longer use the product. Supposedly the web proxy that the company that I work for uses is causing the problem. Are there any workarounds for this?

4 answers

This widget could not be displayed.

Hi Patrick! Can you clarify exactly what happens when you click on Use existing account? I want to discard the possibility that you migh be affected by SRCTREEWIN-7001.

If this is not your case, you can try wiping the SourceTree preferences. If this doesn't solve your issue, let us know if this is happening on Windows or Mac and which SourceTree version are you using so we can continue helping you. 

Cheers :)

Ana

Thank you for the response. I am having this issue on a computer that was reimaged by our IT department with a new developers enviornment after my computer was affected by a virus.

I cannot get SourceTree start to a point where I can specify a new license that I generate via your web site. 

I don't think wiping preferences wil help since this was a first time installation on a computer that was completely reimaged.

Other users at my location are having the same problem. 

Here is what my IT person said:

"Other users have also reported this issue (Jason cc’d), it looks like Sourcetree may not be compatible with the Schneider Electric web proxy. We would need to either make a request Schneider security asking that the specific website and IP addresses used for this application are excluded from the proxy and a firewall rule created to allow direct access or contact Atlassian support to advise if their product is compatible with an authenticated web proxy and if so what needs to be done to make it work. "

I forgot to mention that this is happening on Windows 7.

On Monday I downloaded the latest SourceTree version 2. something. 

What happens exaclty is this:
1) Start App
2) I have two checkboxes that I clicked OK and click on Continue
3) I click on "Use an existing account"
4) A balnk window from with your Atlassain icoon on the top left and an x bar appears.
5) I breifly see an image of our company and see "Please wait for a moment while we launch our secuirty service"
6) The window then becomes blank and never does anything.

It appears that the new version of the application is not compatible with our web proxy. Multiple developers have this issue at our company. 

I have been able to generate a license using the "Go to My Atlassain" but there is now way to use the generate license the current version of SourceTree. 

Hi Patrick

Are you able to open Internet Explorer and log into https://id.atlassian.com ?

It has to be tested via Internet Explorer because the WPF Web View component SourceTree uses relies on Internet Explorer under the covers.

It should respect any proxy settings that you have setup on the OS.

Thank you for the reply.

I am able to log into this from this link. It looks like not all of the text appears in Internet Explorer and I had to guess at the username and password fields but I  eventually reached the "Manage Your Account" screen. 

"Go to my Atlassain" also works as it did previously and I was able to create and download a license. 

The "Use an existing account" still doesn't work and I don't see any way to use my downloaded license.

Sorry for the delay in responding. I was on vacation.

 

 

Hello, have you solved this issue? I have the exact same problem , i choose "Use an existing account" during installation steps and i never get a "Password" field to continue. 

I have Windows 7 Professional

I am also having the exact same issue with sourcetree 2.3.1.0 installer. I Cant install Source tree.  I have windows 7 Pro and have tried adding https://id.atlassian.com to trusted sites disabled pop-up blocker, tried rebooting,  but just get a blank white screen when I select the 'Use an existing account'.  I have verified that I can log into https://id.atlassian.com  and can generate a License.  Is there a work around for this?   

I am also having the exact same issue with source tree 2.3.1.0 installer. I Cant install Source tree.  I have windows 7 Pro and have tried adding https://id.atlassian.com to trusted sites disabled pop-up blocker, tried rebooting,  but just get a blank white screen when I select the 'Use an existing account'.  I have verified that I can log into https://id.atlassian.com  and can generate a License.  Is there a work around for this?   

Exact same issue on Windows 10. I use the newest installer 2.3.1.0, but I just get a blank white Window if I click "Use an existing account"  (an image can be found here https://ibb.co/hjmJ5b). If I click "Go to my Atlassian" I can log in and I'm able to download the licence. But unfortunately the installer offers no possibility to import this licence.

Logging my complaint here too... It seems to be IE related. I can't get IE to load id.atlassian.com but Chrome does just fine. I'm on a fresh Windows 7 install as well. Still running updates... so we will see. 

After a day of Windows updates on the fresh install... it works for me now!

Same issue on Windows 10 when i try to install 2.3.1.0. Only a white dialog is opened and I am not able to use Source Tree. Please fix it! BR

Please see https://jira.atlassian.com/browse/SRCTREEWIN-7244

The login process relies on IE, as this underpins the WF webview.

Workaround

At a minimum IE needs to be configured as follows:

Cog/Internet options/Security settings need to be enabled

  • Misc/Access data sources across domains
  • Misc/Allow META-REFRESH
  • Scripting/Active Scripting

 

  • The browser mode set to 10
  • The document mode set to 10

These can be set using the F12 developer tools.

Those are the settings that matter. It should also be able to set them indirectly by:

  • making sure https://id.atlassian.com is NOT set to be rendered in Compatibility Mode
  • Set Cog/Internet options/Security to Medium-High
This widget could not be displayed.

I also have this problem, exactly as described by Lucas. I can get the https://id.atlassian.com/ to load in Google Chrome, but not in Internet Explorer.

When I press "Use an existing account" I get the same response as F G, just a blank window without the possibility to fill in or press anything.

Please see https://jira.atlassian.com/browse/SRCTREEWIN-7244

The login process relies on IE, as this underpins the WF webview.

Workaround

At a minimum IE needs to be configured as follows:

Cog/Internet options/Security settings need to be enabled

  • Misc/Access data sources across domains
  • Misc/Allow META-REFRESH
  • Scripting/Active Scripting

 

  • The browser mode set to 10
  • The document mode set to 10

These can be set using the F12 developer tools.

Those are the settings that matter. It should also be able to set them indirectly by:

  • making sure https://id.atlassian.com is NOT set to be rendered in Compatibility Mode
  • Set Cog/Internet options/Security to Medium-High

wow great solution. Why to make such dependency which everyone face problem. You can see here how many people are facing problem just because of your dependency on IE which no one use now a days. and creating so many problems to update version as well as to install new new version.

in windows 7 when installing source tree in atlassian account when clicking use an existins account a blank screen coming and loading not opening

My IT department finally figured some way to get it to install but I dread the next time that I have try to install the software after wasting many hours on this issue. I work in a big company and have to use a web Proxy with a user name and login requirement. The Atlassian current approach is extremely painful to use and was not an issue until in earlier major versions.  Atlassian needs to change the clearly extremely flaky install. This inadequate install will definitely impact our future purchasing decisions at the company I work for. 

After spending hours trying to fiddle settings, installing, uninstalling, etc, none of the above and other suggested workarounds worked for me.  I'm moving on now and sadly will not be using SourceTree.

This widget could not be displayed.

I'm too facing the same issue :(

This widget could not be displayed.

We made it work by connecting the account using OAUTH and HTTPS, if I am not mistaken, and providing the password in Sourcetree not through the connect account menu.

I hope this helps. I think we were just lucky in making it work and we don't even want to try reproducing the steps lest we find ourselves back in blank window world.

More context:

We have several computers running macos and windows. We faced it in one macos computer with the exact same OS and sourcetree versions and others. We tried all the proposed solutions an nothing worked.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

862 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you