Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

"Use an existing account" login hangs with white screen and "Please wait..." message

After installing SourceTree and selecting the "Use an existing account" button to login, SourceTree hangs at a white screen with the "Please wait..." message. The problem persists when trying to log into multiple accounts (any account we tried).

Clicking the "Log in with Google" option does nothing. The button is not responsive.

I am trying to diagnose this issue, can anyone help? SourceTree appears to want to use Internet Explorer as the default browser and someone suggested tinkering with the security settings in there, but that does not seem to work. Feels like a client side issue with my account permissions or something, but the problem occurs even when running the program as an administrator.

Has anybody else encountered this issue? Thanks for your time! Please let me know if there is any other information that would be useful.

13 answers

I have the same problem trying to install on server.

Hangs-on forever when trying to login. I have tried all tricks with IE - adding to trusted site, lowering security to min, compatibility modes.

None of them works. 

I wonder, out of all options out there for making a login, why on earth would anyone choose the shittiest piece of software ever built for this purpose (yes, Internet Explorer). I bet it takes more time to integrate IE and make it work into a desktop app, than it would take to make a login from scratch. 

Try running as administrator, gets me logged in and then everything else appears to work normally. 

But I agree it is clearly a major problem with this piece of Atlassian software that it has been poorly tested (if tested at all).

Like Hugo Nogueira likes this

I was logged in as admin, but IE didn't care about that.

Anyways I was inspired enough to google how to completely disable the IE security. And though I didn't find exactly that, I found an answer describing how to disable some of it. Goes like this:

Open Server manager -> Local servers 

There you will find an option on the right side:
IE enhanced security configuration

I set this option to Off and then I was able to login from the source tree installer. 

I still hate IE with passion.

Thank you, Andrei, turning off this option resolves my problem. I was about to contact atlassian for support when I saw this post. How lucky!

Really you want to check this option if:

1. You are on windows server as Andrei mentioned.

2. You have tried other options and are able to login to website with the same email/pwd in IE directly, but still cannot login via source tree.

Added to Trusted sites in IE and worked!!!




This also worked for me.  Thank you for posting your solution!

I initially added to my local intranet group, and my next attempt showed me that it was trying to get to from  I added both urls to my trusted sites and was able to log into sourcetree finally.

This was after lowering the IE security level to lowest and making sure that "Enhanced Security" for IE was turned off in Server Manager (it had been off all along).

Windows Server 2012 R2/Sourcetree

Here's what worked for me (I think I needed all of the following):

  1. Add to Trusted Sites as people have explained above.
  2. Set security on Trusted Sites to Low (remember to reset it after installation).
  3. Run as Administrator as people have explained above.
  4. (*The secret ingredient*) When you enter your credentials and click the button you will get prompted for the Trusted Site a couple of times.  Then a spinner will appear in the button and it will _freeze_ after about one second.  Right-click the login modal window and click Refresh (it's a web page so you're actually getting the IE context menu).  After a pause it told me I was all done.

GENIUS! That worked for me too.

Worked for me as well, AMAZING, Thanks !!!!

not working at all

I've got the same problem (we tried different accounts; same installation procedure runs perfectly on my colleagues pc from the same network and firewall settings; we tried different networks/wifis; tried to login with administrator rights)

Did you find a solution yet?

The solution to my problem was changing the security settings of microsoft internet explorer from high to medium. 

Thanks for posting this!

I achieved success in a similar fashion by adding to the Trusted Sites list in IE.Internet Options.Security.Trusted Sites.Sites. (SourceTree 1.8.3 on Win2012R2)

TIP : Open IE on your target workstation/server and try to log into yourself. If you cant log in then the SourceTree cant either.

Same problem, gave up.


This is is just stupid!!! We can't install sorcetree on a brand new windows 10... Login to the account is successful but installation freezes on this panel.

Yeah this is pretty pathetic. I guess this is what happens when you once upon a time had a great piece of software and now you're just a software developer congregation. Tried tons of things and nothing really works. How many hundred (or even thousands) of devs does Atlassian now employ and they can't even sort this nonsense out. Bet they've become like every other dev factory with shitty bloated software and "more important things to do" than fix the installer. Will move to GitKraken.

After one year your product still not installs correctly on a "out of the box" windows 10 laptop, it's a shame, switched to GitKraken.

Update: just in case someone around would prefer to stick with a broken product, this workaround worked on my box

Very nastily I tried all of the above but in the end took another hunch and tried running as administrator... and it worked.

What worked for me in the end was to disable IE's pop-up blocker.

Change the security settings in the internet explorer to low

I'm currently running into this on my laptop, but somehow wasn't an issue on my desktop pc the other day.

Have you had any luck?

Sorry for the long-delayed reply. I am no longer working on that computer and have not run into the same problem on other devices. Check out Johnop's solution below though if you are still having problems; maybe it will help.

I am troubled with the same trouble as you.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events