"Use an existing account" login hangs with white screen and "Please wait..." message

After installing SourceTree and selecting the "Use an existing account" button to login, SourceTree hangs at a white screen with the "Please wait..." message. The problem persists when trying to log into multiple accounts (any account we tried).

Clicking the "Log in with Google" option does nothing. The button is not responsive.

I am trying to diagnose this issue, can anyone help? SourceTree appears to want to use Internet Explorer as the default browser and someone suggested tinkering with the security settings in there, but that does not seem to work. Feels like a client side issue with my account permissions or something, but the problem occurs even when running the program as an administrator.

Has anybody else encountered this issue? Thanks for your time! Please let me know if there is any other information that would be useful.

11 answers

This widget could not be displayed.

I have the same problem trying to install 2.3.5.0 on server.

Hangs-on forever when trying to login. I have tried all tricks with IE - adding to trusted site, lowering security to min, compatibility modes.

None of them works. 

I wonder, out of all options out there for making a login, why on earth would anyone choose the shittiest piece of software ever built for this purpose (yes, Internet Explorer). I bet it takes more time to integrate IE and make it work into a desktop app, than it would take to make a login from scratch. 

Try running as administrator, gets me logged in and then everything else appears to work normally. 

But I agree it is clearly a major problem with this piece of Atlassian software that it has been poorly tested (if tested at all).

I was logged in as admin, but IE didn't care about that.

Anyways I was inspired enough to google how to completely disable the IE security. And though I didn't find exactly that, I found an answer describing how to disable some of it. Goes like this:

Open Server manager -> Local servers 

There you will find an option on the right side:
IE enhanced security configuration

I set this option to Off and then I was able to login from the source tree installer. 

I still hate IE with passion.

Thank you, Andrei, turning off this option resolves my problem. I was about to contact atlassian for support when I saw this post. How lucky!

Really you want to check this option if:

1. You are on windows server as Andrei mentioned.

2. You have tried other options and are able to login to atlassian.com website with the same email/pwd in IE directly, but still cannot login via source tree.

This widget could not be displayed.

Added https://id.atlassian.com to Trusted sites in IE and worked!!!

 

image.png

image.png

This widget could not be displayed.

Here's what worked for me (I think I needed all of the following):

  1. Add to Trusted Sites as people have explained above.
  2. Set security on Trusted Sites to Low (remember to reset it after installation).
  3. Run as Administrator as people have explained above.
  4. (*The secret ingredient*) When you enter your credentials and click the button you will get prompted for the Trusted Site a couple of times.  Then a spinner will appear in the button and it will _freeze_ after about one second.  Right-click the login modal window and click Refresh (it's a web page so you're actually getting the IE context menu).  After a pause it told me I was all done.

GENIUS! That worked for me too.

Worked for me as well, AMAZING, Thanks !!!!

This widget could not be displayed.

I've got the same problem (we tried different accounts; same installation procedure runs perfectly on my colleagues pc from the same network and firewall settings; we tried different networks/wifis; tried to login with administrator rights)

Did you find a solution yet?

The solution to my problem was changing the security settings of microsoft internet explorer from high to medium. 

Thanks for posting this!

I achieved success in a similar fashion by adding https://id.atlassian.com to the Trusted Sites list in IE.Internet Options.Security.Trusted Sites.Sites. (SourceTree 1.8.3 on Win2012R2)

TIP : Open IE on your target workstation/server and try to log into id.atlassian.com yourself. If you cant log in then the SourceTree cant either.

This widget could not be displayed.

I am troubled with the same trouble as you.

This widget could not be displayed.

I'm currently running into this on my laptop, but somehow wasn't an issue on my desktop pc the other day.

Have you had any luck?

Sorry for the long-delayed reply. I am no longer working on that computer and have not run into the same problem on other devices. Check out Johnop's solution below though if you are still having problems; maybe it will help.

This widget could not be displayed.

Change the security settings in the internet explorer to low

This widget could not be displayed.

What worked for me in the end was to disable IE's pop-up blocker. 

https://stackoverflow.com/a/45063640/855107

This widget could not be displayed.

Very nastily I tried all of the above but in the end took another hunch and tried running as administrator... and it worked.

This widget could not be displayed.

After one year your product still not installs correctly on a "out of the box" windows 10 laptop, it's a shame, switched to GitKraken.

Update: just in case someone around would prefer to stick with a broken product, this workaround worked on my box https://stackoverflow.com/questions/36467893/sourcetree-installation-atlassian-login-stuck/46669458?noredirect=1#comment82510007_46669458

This widget could not be displayed.

Yeah this is pretty pathetic. I guess this is what happens when you once upon a time had a great piece of software and now you're just a software developer congregation. Tried tons of things and nothing really works. How many hundred (or even thousands) of devs does Atlassian now employ and they can't even sort this nonsense out. Bet they've become like every other dev factory with shitty bloated software and "more important things to do" than fix the installer. Will move to GitKraken.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

733 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you