Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,346
Community Members
 
Community Events
176
Community Groups

"SSL certificate problem: self signed certificate in certificate chain"

I am using SourceTree on a Windows 10 host.  I added the path to the git.exe (C:\Users\fisherju\AppData\Local\Atlassian\SourceTree\git_local\cmd) to my Path environment variable so that I can use git from the command line. 

Initially I was getting the same certificate errors while using git.exe. I reviewed many posts online for fixing this error.   Configuring git to use schannel corrects the problem from the command line.  I can also use the method for configuring openssl to use a ca-bundle.crt file.

I can use git from the command line successfully and from the "terminal" from inside of SourceTree.  However I can not use SourceTree without setting the option git option to "Disable SSL certificate validation".  

How do I configure SourceTree to use schannel so that it can correctly perform SSL certificate validation.

0 answers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events