Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

"No supported authentication methods available (server sent: publickey)"

Software installed:

  • SourceTree 2.3.5.0 - from the latest ST installer.
  • (embedded) Git 2.14.1.windows.1 - the latest included with the latest ST installer.
  • Pageant 2012-06-04:r9551 - from the latest MSI installer for putty/puttygen/plink/pageant.


Today started out fun. I've been using the old SourceTree client for over a year, with key authentication via pageant. Today my co-worker changed permissions settings on the bucket, and I found that I could no longer access a couple of repositories via SourceTree - it kept prompting me for a username and password. Through the git CLI, I was still able to perform all the usual tasks on the sasme repository using username/password authentication.

In an effort to fix this, I updated all software to the latest versions installed. No dice, it still wouldn't work. So I created a new key, and add it to pageant and bitbucket, deleting the old key from both. I only have one key.

Under "Edit hosting account" for my only BitBucket account, I have "preferred protocol: SSH", as per the instructions. I have the green tick and "Authentication OK".

Under repository settings, I have my origin path. In there, the URL is ssh://bitbucket.org/~~/~~, host type is bitbucket, username is my username - the one that works through the CLI.

Everything is looking good, right? Until I try to do anything, upon which I receive the error message above. If I try to use the git CLI, I'm told that it can't communicate with my authentication agent.

How do I resolve this?

1 answer

0 votes
minnsey Atlassian Team Dec 28, 2017

Hi

Is Pageant running, with your key leaded, in your system tray when this fails? It sounds like it isn't, but that might be too simplistic.

It is running.

minnsey Atlassian Team Jan 18, 2018

Sorry another simplistic question are you using a key or username/password for the SSH connection? If it is a key is it loaded in Pagaent?

"I created a new key, and add it to pageant and bitbucket, deleting the old key from both. I only have one key."

@minnsey Don't you think it's terrible customer service when you ask questions which are answered by copying and pasting from the original question?

minnsey Atlassian Team Mar 06, 2018

Sorry, simply a mistake on my behalf.

Can you post up the error you get from the CLI? Thanks

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,387 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you