Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,315
Community Members
 
Community Events
176
Community Groups

"Mergetool path issue" when launching external merge tool (OSX)

Edited

When I choose "Launch external merge tool" I get

Mergetool path issue

Current path:/Library/Developer/CommandLineTools

Please set the command tool path in Xcode and Try again!

I don't know what this means or how to fix

External diff tool works fine

I have Sourcetree 4.1.3

xcode-select --print-path

displays
/Library/Developer/CommandLineTools

(same path referred to in error message)

 

I tried

sudo rm -rf /Library/Developer/CommandLineTools

 Sourcetree immediately prompted me to instal Xcode.  Which I did.

Still get the error

Reverting to Sourcetree 4.1.2  (or 4.1.1) solved issue

12 answers

Solved for me by ensuring Command Line Tools were set correctly in Xcode (Preferences->Locations).

For some reason this was not set.

Thank you, this did the trick for me as well.

Like # people like this

@mikepearce Doing this and restarting SourceTree did the trick for me. Thanks!

Like # people like this

Worked for me, v4.1.5

So, maybe the issue is coming when Xcode is not installed? I only have the command line tools installed. Downgrade to 4.1.1. worked out for me. I kinda don't want to install Xcode as I don't use it at all.

Like # people like this

This worked for me on 4.1.8. Unfortunate for people who don't want to install Xcode though :-/

Reverting to 4.1.1 fixed this for me.

Download here: https://www.sourcetreeapp.com/download-archives

Reverting to 4.1.2 fixed the problem also on my side.

Like SyedH likes this
Deleted user Dec 09, 2021

Not being able to launch my KDiff3 merge tool to resolve conflicts is is a big problem for me. Downgrading to 4.1.2 as suggested above fixed it for me.

@Bradley Kent  Did you install Xcode? If yes, then could you please check the Xcode tool path using this command "xcode-select --print-path". Also, Could you please share the system information?

same problem occurred for me using sourcetree version 4.1.3 (239)

for command "xcode-select --print-path"
printed "/Library/Developer/CommandLineTools"

system information "uname -a"

Darwin xxxxx.local 20.6.0 Darwin Kernel Version 20.6.0: Wed Jun 23 00:26:31 PDT 2021; root:xnu-7195.141.2~5/RELEASE_X86_64 x86_64

note: trying to use Kdiff3

Like # people like this
1 vote

This is a bug, here is the ticket, as pointed out in other answers: https://jira.atlassian.com/browse/SRCTREE-7737

The bug is finally fixed in 4.2.0, build date 24-Aug-2022 (see https://www.sourcetreeapp.com/download-archives).

Installing Xcode is not a viable workaround, as xcode shouldn't be a required dependency for sourcetree. I do not have xcode installed, I confirmed the issue is resolved in 4.2.0. For anybody still stumbling on this issue, upgrade to 4.2.0, should do the trick.

vmpj I'm New Here Nov 25, 2022

I still got the same issue on 4.2.0. Downgrading to 4.1.2 also did not help.

Only fiddling with location settings in XCode, as described here, fixed it for me.

Same issue in 4.1.7.

I do not have Xcode installed.

Searching Sourcetree docs for "requirements", "xcode" gives no results.

Hmmm... this bug has existed for ~5 months.  SourceTree doesn't seem to receive bug fixes quickly.  Going to explore Fork instead.

Fork is working well for me.  But since I like the "Reverse Hunk" feature of SourceTree, I thought I'd give it another shot.

I was not successful with v4.1.6. (sadness).  Anyone else explore v4.1.6?

 

SourceTreeMergeIssue.png

Okay, normally I hate these "Fix my bug or I'm out of here!" posts, especially for free (if not Free) software, but I might make an exception this time. ;) 

With Fork, you can collapse all merge commits and only display those you need right now. Collapse all branches using the context menu of the graph and expand the ones you’d like to keep.

Hellll-low nice. I was just complaining about not being to do this today.

(Dirty secret: On Windows, I still use SourceTree v1.7 precisely to avoid these sorts of overly common dealbreaking bugs. I've yet to regret it.)

Same issue here with 4.1.3

I have exactly the same issue.. on 4.1.3

Same issue here with 4.1.3

I reinstalled xcode tools and I'm facing the same issue.

Like Joris Joris likes this

Downgrade to 4.1.1 fixed the issue for me.

Has this been resolved in the latest release?  Still seems to be an issue.

same issue on version 4.5.1 (241)

I had it working fine before but can't get my merge tool to work with my new Mac

4.1.5 (rather than 4.5.1)?

I guess this issue is the same as reported here?
https://jira.atlassian.com/browse/SRCTREE-7737

Same problem here. I reinsetalled XCode and command line tools and now having the same issue. 

Downgrading to 4.1.2 fixed it for me.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events