Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,463,027
Community Members
 
Community Events
176
Community Groups

"Error: remote: Too many invalid password attempts", despite authenticated App Password

Edited

I'm baffled (and Atlassian Support is baffled, too) at the error I'm getting in Sourcetree when attempting git commands from a valid authenticated Bitbucket remote:


"Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://dkouts@bitbucket.org/myteam/myrepo.git
Output:
Error: remote: Too many invalid password attempts. Log in at https://id.atlassian.com/ to restore access.
fatal: unable to access 'https://bitbucket.org/myteam/myrepo.git/': The requested URL returned error: 403"

 

Background:

  • Problem started after installing SourceTree 3.4.7 on a freshly-installed Win10 two days ago.
  • The remote Bitbucket account is valid!  I can add it to the remote accounts in Sourcetree  without any issues:
    • OAuth, refreshing the token: "Authentication Ok"
    • Basic (using a recently-created App Password): "Authentication Ok"
  • Doing a refresh in the Remote repositories page brings up my team's repos as expected.
  • Git commands in Sourcetree:
    • Clone from a valid repo https url, the Clone page says "This is not a valid source path / URL", and the Details button brings up the 403 error.
    • Fetch from a local repo brings up the 403 error.
  • Git commands in the terminal:
    • OpenSSH dialog asks for the account password.  If I enter the App Password, it completes successfully.

 

I've tried all of the following, with no change:

  • Logged out and in of https://id.atlassian.com/, per the error message.
  • Cleared all the Bitbucket credentials in Credential Manager.
  • Uninstalled and reinstalled Sourcetree.
  • Removed and re-added the account in Sourcetree in Remote repositories.
  • Removed and re-added the account in Sourcetree in repo settings.
  • Updated Sourcetree to 3.4.8 this morning.
  • Contacted Atlassian Support (they said they have no 403 responses in their logs, and that they do not see a problem on their end).

 

...help?

1 answer

1 accepted

1 vote
Answer accepted

Update:

I don't know what happened, but after doing the following (again, I tried this process multiple times yesterday) this morning, I'm no longer getting the error:

  1. Uninstall Sourcetree
  2. Remove Sourcetree folders in %appdata%\Local and %appdata%\Roaming
  3. Clear all Bitbucket credentials in Credential Manager
  4. Reinstall Sourcetree (I used 3.4.7)
    1. Skip the initial account creation during install
    2. Use default settings
  5. Add account (using App Password, not OAuth)

I have no idea why it started working this morning, but perhaps the above will help someone.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events