"Error generating password due to missing uuid" when pushing changes to github

I am getting the following error when trying to push local changes to github:

 

2018-01-18 14:07:39.128 git-credential-sourcetree[51532:6668251] Error generating password due to missing uuid. Please report this to Atlassian.

 

I am reporting as asked :-)

12 answers

1 accepted

1 vote
Dong Wook Baek I'm New Here Sunday

Try changing "embedded git" to "system git" in Settings. It worked for me.

Nice job, @Dong Wook Baek! Works for me as well.

To Atlassian folks: I have installed version 2.7.1 and it still does not work when "embedded Git" is used: it does not show the original error, but just hangs during a push, as described previously.

So what @Dong Wook Baek found is just a workaround, but a good one--everything seems to be working and I am not sure if there is anything that I am missing by using "system Git" vs "embedded Git"?

I have the same issue and deleting the com.torusknot.SourceTreeNotMAS.plist didn't solve the problem :-(

FYI: I'm using SourceTree 2.7 (152)

Screen Shot 2018-01-22 at 13.26.36.png

2 votes

Hello gyis ,i have one solution to help me ,you need only to set url like on photo,if u use https ,push button and shose your poject and url chosed by program.Screen Shot 2018-01-25 at 11.59.43 AM.pngScreen Shot 2018-01-25 at 11.59.18 AM.png

I figured it out on my end. It's so odd, because it was working earlier this week.

This was my fix:

Sourcetree>Preferences>Accounts>Add

I had to make sure my account is HTTPS protocol, added my username and password, and it's now working...

I'd recommend you to delete the com.torusknot.SourceTreeNotMAS.plist located at ~/Library/Preferences/ and launch the app again. This should generate the missing UUID and allow all actions thereafter. 

Thanks!

Xuan Liu I'm New Here Jan 21, 2018

It does not work with SourceTree 2.7 update.

It's really a shame that providing a overkill and it does not work. And it ruined my settings. 

The same error here.

I also suspect that version 2.7 broke support for SSH key on PKCS#11 device - it doesn't work either. Pushing from command-line now :-/

As far as ssh support is concerned, please make sure your keys are loaded to the ssh agent on macOS. Run below command to check loaded keys and add it if required. 

ssh-add -l
ssh-add <path_to_key>

 

Coming back to missing UUID issue, I would appreciate if some one facing this issue can check the com.torusknot.SourceTreeNotMAS.plist located at ~/Library/Preferences/ for the key "anonymousUUID" and see if its present and non nil. I assure you that we are looking in to this issue and help you resolve this asap with your cooperation. Also, this is happening for users moving to High Sierra only. Appreciate your cooperation and patience. 

Thanks,
Manjunath
Sourcetree Mac Developer

Hi, on my case i see somethng like

    <key>anonymousUUID</key>
    <string>EF7F35E7-E51E-49E4-B79A-0B0806C6FAFC</string>

But still get the same error. I've tries to go back to a previous version (2.6.3), but i get an Authentication error problem.

Xuan Liu I'm New Here Jan 22, 2018

In my  case,

208     <key>anonymousUUID</key>                                                                            

209     <string>B7B12FC8-57A8-4D60-83B6-A63BB5E5A4E3</string>

also present. Really? That's how sourcetree updated

please make sure your keys are loaded

which keys are you referring to and how do you find them?

 

this issue appears to have been triggered on my machine by changing my password, then deleting a couple saved items relating to git/github in my keychain

Encountering this same problem.

2018-01-31 08:19:16.202 git-credential-sourcetree[6129:118515] Error generating password due to missing uuid. Please report this to Atlassian.
2018-01-31 08:19:16.202 git-credential-sourcetree[6129:118515] Password encryption failed - key to to encrypt password is unavailable (nil)

Tried doing the toggle of Use global user settings, but that did not work.

Tried deleting the com.torusknot.SourceTreeNotMAS.plist as well as reinstalling, no luck.

AnonymousUUID reads:

<key>anonymousUUID</key>
<string>E518814D-7FA0-4DE7-9952-19CF1AB690D4</string>

 

Note the error is only within SourceTree.  If I go back to using command line git, everything works fine.

Same issue as @Matt Satorius, key has a non-nill value but doesn't work.

I just fixed this on my machine by turning "Use global user settings" off and on again.

I see no such setting in SourceTree 2.7 (Mac)

I fixed this by turning off "Use global user settings" under Advanced, then turning it on again.

Random user here who just learned Sourcetree for personal version control on his Unity projects.

I'm on High Sierra 10.13.2, problem seems to have been fixed on my end by uninstalling (deleting the Sourcetree app in Applications folder and the com.torusknot.SourceTreeNotMAS -related files), then installing an older version (2.6.3a).

Screen Shot 2018-01-27 at 1.29.12 AM.pngScreen Shot 2018-01-27 at 1.29.32 AM.png


Still having the same problem where I have to constantly go in Settings -> Edit Account Info, input my password for it to authenticate any form of pushing, but this at least lets me push things out from my Mac.

Hope this helps someone.

Can you try this build and give me all the logs that you get?

https://drive.google.com/file/d/1qM8VRBtr-m_d0lge8Nfs1RtTtBG62JBo/view?usp=sharing

This would help us identify and resolve the issue.

Appreciate your help on this.

 

Thanks!

This works sometimes and sometimes we still get that stupid pop-up message. 

Password Required

Followed by the following error messages:

 

Standard input = protocol=https
host=bitbucket.org
protocol: https
host: bitbucket.org
Auth type - 0
Trying to get password for username xx@xx.com and host bitbucket.org
Attempting to get account
Error fetching password for SourceTree (OAuth) for Bitbucket account with username xx@xx.com.
Error Description - The specified item could not be found in the keychain.
Something went wrong. one or more parameters required to renew token is nil.
UUID - (null)
username=xx@xx.com
password=(null)

 

I can't pull or push sometimes.

After installing version 2.7..1 (156) the pushing "hangs", i.e. I see a message saying

    Pushing to https://github.com/account/repo.git

but nothing happens after that and I have to cancel eventually. This is after deleting blah.SourceTreeNotMAS.plist from Library/Preferences

Pushing from command line (git push) works as expected with no authN prompts.

I am running 2.7 (152) on High Sierra. I fixed the problem by going into Preferences / Accounts, and forcing a "reconnection" (HTTPS) of the Github account that was causing me issues. I still initially get errors when I try to push, but then it works, all without any intervention or re-trying on my part.

2018-02-11 11:08:47.481 git-credential-sourcetree[42829:18369525] Error generating password due to missing uuid. Please report this to Atlassian.

2018-02-11 11:08:48.475 git-credential-sourcetree[42835:18369714] Error generating password due to missing uuid. Please report this to Atlassian.

2018-02-11 11:08:48.476 git-credential-sourcetree[42835:18369714] Password encryption failed - key to to encrypt password is unavailable (nil)

Same here. Still terrible, but at least I can push now.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

273 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot