Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,475
Community Members
 
Community Events
176
Community Groups

"Error: System.ComponentModel.Win32Exception: Access is denied" error in Sourcetree

Edited

Hello,

Some of the users from our organization are getting the below error while trying to clone the repository using sourcetree. Can you please help me to resolve this issue ?

Error Message:
=========================================

Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote https://bitbucket.collaboration.agilent.com/scm/TT/TT.git

Output:

Error: System.ComponentModel.Win32Exception: Access is denied
=========================================

2 answers

0 votes

This usually means that the account running your application does not have the necessary permissions to run the software.  That's something set up in the operating system, it's not a software fault.

Is your user allowed to run git on your system?  Try running the command on the command line, outside Sourcetree - do you get the same error?

Thanks for your response. Do you know how to enable the access in OS level ?

 

We requested user to install Git bash and clone any one of the repository to see if it is working. I am waiting for the user to come back to me.

(Meant this as a reply)

I am also seeing this issue in SourceTree.

 

  • Tried clearing out all user settings, uninstalling and reinstalling.
  • The same command works in Terminal
  • git works in Visual Studio
  • git commands in Terminal work
  • Other GIT apps work (but I prefer to use SourceTree)
  • Same issue with GitHub and Azure Devops Repo
  • All git related buttons functionality doesn't work
    • History doesn't show
    • Cannot Pull
  • Running the latest ver 3.4.10
  • I do notice that the Certificate on the exe expired on 11/27/2022
    • Can this be updated in an installer? 

We are also having the same issue.

I have tried all of the same things Andrew listed.

  • If the user does a run-as administrator on SourceTree it will work as expected, but they should not need to do that every time they run the application.
  • We installed 3.3.9 and it worked for a day, but then stopped working again.
  • We tried switching to the Embedded Git, restarted and then went back to the system Git.
  • Tried removing the .NET updates that were installed around the time it broke.
  • Tried moving the local repository to another folder.

Not able to get anything to work so far.  Any help would be great!

Hi, I found this other discussion about the certificate for the SourceTree.exe. 

 

https://community.atlassian.com/t5/Sourcetree-questions/Digital-signature-certificate-has-expired/qaq-p/2211112

 

There is a planned release with the new certificate in 3.4.11

Like Jason Brinkmann likes this

The cert expiration and the date the app stopped working is the same.  Hopefully the new version will be out soon.  Thanks for sharing!

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events