It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

marked as requiring a CAPTCH error

When using source tree I keep getting this error a few times a day. After I logout of Stash and log backin with a captha it starts working but I'm getting very tired of doing this mulitle times a day. Any fix would be awesome.

I should add I'm using OS X 10.8.5.

git -c diff.mnemonicprefix=false -c core.quotepath=false -c credential.helper=sourcetree fetch origin 
fatal: remote error: CAPTCHA required
Your Stash account has been marked as requiring a CAPTCHA to be solved before
you may login again. This is typically caused by too many attempts to login
with an incorrect password. The required CAPTCHA prevents your SCM client from
accessing Stash until it is solved, even if you enter your password correctly.

If you are currently logged in to Stash via a browser you may need to logout
and then log back in in order to clear the CAPTCHA.

Visit Stash at http://git.dev.dice.com for more details.
Completed with errors, see above

1 answer

1 vote

Hi Jared,

Could it be that you've changed your credentials and that something (perhaps a Bamboo/Jenkins/.. build?) is still using your old credentials? If you need to figure out what IP address the authentication failures are being triggered from, you could have a look at the audit logs in STASH_HOME/log/audit. The atlassian-stash-audit.log file should contain entries like:

0:0:0:0:0:0:0:1 | AuthenticationFailureEvent | - | 1392111196025 | username | {"authentication-method":"form","error":"Invalid username or password."} | 633x670x0 | 1xzqso0

where the first component is the IP (in my case localhost in IPv6) of the calller.

Hope this helps!

Michael

I bet your correct, I started having the problem after I had to update my password. Unfornetly I don't have access to the server that Stash is on so I dont think I can get to the logs. I will have to work with our help desk, thanks.

I am getting the same error on an old version of Stash after having logged in as myself on a coworker's computer. We've cleared the cookies on his browser and closed it, and I've done the same on mine. I can log out and log in to our Stash interface with no problem. I used an invalid password enough times to get a CAPTCHA, but still when I try to use git to pull from Stash I get this error. I had my manager set my number of failed logins before CAPTCHA to 10, and that's the only thing that's "solved" the problem, but is there a definitive way to clear some flag out of the system to keep this error from reappearing if the failed login setting is put back to the default 5? And "upgrade" is not the answer I'm looking for. Thanks.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,970 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you