how to reslove 'ssh-agent' failed with code-1: System.NullReferenceException: Object reference not set to an instance of an object.

abhijeet Kamle February 16, 2016

I currently up source tree to latest version of source tree i.e 1.8.1 and then I try to open the source tree, i am facing some error message like "how to reslove 'ssh-agent' failed with code-1: System.NullReferenceException: Object reference not set to an instance of an object."  can some one please help me to resolve the issue.

6 answers

4 votes
Nukezm February 16, 2016

Install newest version of git

danchadwick February 17, 2016

+1. The update process for the internal version of git failed to install, but I was able to switch to the system git, update from 1.8 to 2.7, and the ssh-agent issue was resolved.

Sukanya Naramreddy October 24, 2018

same issue i am getting git version is 2.6.3 and source tree version is 2.3.5 so please help me how to resole it.


Awaiting for response!

3 votes
Kamil B February 16, 2016

Atlassian! seriously?!

Best solution... uninstall this s...

3 votes
ankti patel February 16, 2016

I updated git bash and integrate to the source tree via Tool > Option > Git > Use System Git

It worked 

abhijeet Kamle February 16, 2016

I fallow same steps, but having same error message window comes.



image2016-2-17 12:3:36.png

ankti patel February 16, 2016

Step I did : 

1>  Update embedded Git (Tool > Option > Git > "Update Embedded Git" - button)

This will download PortableGit.7z at "<user-folder>\AppData\Local\Atlassian\SourceTree"

2> Extract PortableGit.7z

3> Use as system git (Tool > Option > Git > Use System Git)

select "\bin\git.exe" from extracted folder

abhijeet Kamle February 16, 2016

I fallow same step except in step 3 i select Use Embedded Git option and issue has gone. thanks


jose suarez February 17, 2016

Excellent, I got same issue and like said Kamle I just select "Use Embedded Git" option  too and work, thanks!

Teenage February 17, 2016

ankti pate answer did the job, but Sourcetree auto upgrade failed, it could not dezipp the PortableGit.7z.

This is how I managed to fix it :

  1. Launch update Embedded Git (tools/options/git)
  2. If it failed : close sourcetree
  3. Go to "<user-folder>\AppData\Local\Atlassian\SourceTree"
  4. Rename  git_local to git_local_old
  5. Unzipp PortableGit.7z manually (with 7zip)to git_local
  6. restart sourcetree
  7. Go to (tools/options/git and check that Use Embedded Git is hcecked and the version is 2.6.1
0 votes
Mukesh Kumar
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
December 26, 2023

Hi @abhijeet Kamle , @Sukanya Naramreddy , @danchadwick ,  @Teenage 

Reinstalling Sourcetree resolves that Error.

Sometime few users also reported ssh-agent issue related to User account permission. There can be other instances too but in this particular issue, we have the following reason.

When Sourcetree crashes:

If the ssh-agent process is already running under Admin Privileges and Sourcetree (does not have Admin Privileges) tries to access it, then it can not (Windows don’t allow it). So if 'OpenSSH Authentication Agent' service (ssh-agent) is already started automatically on windows startup as Admin then Sourcetree will crash when it tries to access the ssh-agent process.

When Sourcetree works fine:

If the ssh-agent process is not already running/started then Sourcetree launches the ssh-agent process under its own access privileges and everything works fine.

Kill the already running ssh-agent process in Services in Task Manager and try re running Sourcetree as it can launch its own ssh-agent under his access rights.
If any user is having this issue we are showing following error message and suggestion to resolve the issue:

0 votes
Tomasz Bednarski February 16, 2016

@Craig Chapman is right. Installing newest version is solution in this problem. It also helped me.

0 votes
abhijeet Kamle February 16, 2016

I installed git version 1.9.5 but still facing  same issue.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events