gitolite authentication failure

I've created a gitolite server. I configured my Linux user as the administrator of the gitolite-admin project. From 3 different machines I was able to clone the repository with no problem using my private key. 
On my own machine I keep on getting "authentication via SSH keys failed".

I am using pageant. I reinstalled source tree and pagenat but still get the same result. I am able to connect with SSH (putty and winscp) to my user on the server, using my private with pageant.

in all machines I run the same sourcetree version 1.6.11.0.

Any ideas how to proceed?

1 answer

This widget could not be displayed.

Is there any chance you did not properly install this public key on the server?

I'm 100% sure I have the correct pair and it is installed properly, It works for 3 out of 4 computers. There is something (I think in the sourcetree) on my machine that fails it, and I can't find it.

To determine whether it is sourcetree, try the same operations from the command line (launch from the Terminal button in Sourcetree's interface).

I get "Permission denied (public key)". But if I take down the pageant I keep on getting the same error, I would expect to get a message that it can't open a connection to the authentication agent. Does it mean that maybe I have another authentication agent I am not aware of? I tried to look for such one in the task manager, but couldn't find any.

Idk, maybe. Either way, the problem isn't specific to Sourcetree, so you may have better luck on a stackexchange site. If you get an answer there, though, post a link here.

I have winscp installed on the machine as well. Winscp also uses pageant if you don't specify a specific private key. I tried winscp when pageant was not running and it couldn't authenticate, then I started pageant and winscp authenticated. So I think the problem is something between source tree and pageant.

Except you can't connect from the command line either, which narrows down the issue even more - it is between GIT (or Hg, you haven't specified) and pageant. It is certainly possible someone here knows something, but Atlassian does not develop either Git or Hg, it just calls the appropriate commands. If those fail, it passes the error back to the user to figure out.

I found the issue with the command line git. I had to convert my key to openssh and put it in my %USER%/.ssh/id_rsa. now I am able to clone my repository. So I am back to the situation that sourcetree and pageant fail to authenticate.

now I got the openSSH work for me also from sourcetree GUI. So at the mean time I can work, but I am still puzzled why source tree fails to authenticate with the pageant.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

874 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you