Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

git svn in SourceTree 3.4.1 (Windows)



I'm trying to use git-svn via SourceTree on Windows 10. Unfortunately I'm already failing to clone the svn-Repository. It is hosted by a visualSVN-Server. I get the following Error:


Command: git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks ls-remote <myrepo>
Error: fatal: repository '<myrepo>' not found

Command: perl.exe <SourceTree-InstallPath>\tools\ info <myrepo>
Error: System.ComponentModel.Win32Exception: The system cannot find the specified file


It seems that SourceTree is able to recognize this repository as svn repository, because it is trying to call perl and execute the svn perl-script. I tried installing ActivePerl and StrawberryPerl. This changed nothing on the error message. When trying the perl command by myself on the cmd both can't compile the "" script because they can not resolve "SVN::Client". I am not able to see where to get this module or how to install it.

Based on older (Blog) Posts about SourceTree 1.4 I assume that where was a time this feature worked also on Windows.

So what am I doing wrong or what is missing to get git-svn working with SourceTree on Windows?

Is Perl really the issue or is something else causing this error? Sourcetree is not very clear at this point what the problem is. I'm just guessing around based on the messages, but as said installing perl does not change the error. So perl.exe maybe is not the file which can not be found...

Do I need other dependencies I'm not aware of yet?

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events