Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

'git status' failed with code 128: error: bad signature fatal: index file corrupt

The moment I start up my sourceTree, I get this error. How to resolve it without damaging my current project files?

9 answers

1 accepted

17 votes
Answer accepted
rrudnicki Atlassian Team Oct 07, 2015

Hi Ralph, 

 

If the problem is with the index as the staging area for commits (i.e. .git/index), you can simply remove the index (make a backup copy if you want), and then restore index to version in the last commit. On SourceTree shell run:

On OSX/Linux:

rm -f .git/index
git reset

On Windows:

del .git\index
git reset

(The reset command above is the same as git reset --mixed HEAD)

 

 

Cheers, 
Renato Rudnicki 

Thanks, this solved the problem however it surprises me that I had to use the OSX/Linux command on my windows machine.

 

Like Ts_epo_Mphongoa likes this

Use OSX/Linux command on my windows machine +1

git reset


error: inflate: data stream error (invalid code lengths set)
error: unable to unpack 64e00659b39bc2ec92b15903426745a9ca0e7469 header
error: inflate: data stream error (invalid code lengths set)
fatal: loose object 64e00659b39bc2ec92b15903426745a9ca0e7469 (stored in .git/objects/64/e00659b39bc2ec92b15903426745a9ca0e7469) is corrupt

I too had to use the Above OSX/Linux command on my machine as well....

Like squiggle400 likes this

Technically it did work and got me past that error.

However, it now shows a ton of stuff that I didn't change nor do I want to commit. When I just try to stash everything to get back to where I was it tells me "You do not have the initial commit yet". This reset resets more than I realized it would and caused different issue. 

Im getting an errorcode 128, "ref/heads ... does not point to a valid object!"

Could it be its looking for a remote tree which has been deleted? I noticed the branch i was in has been merged already. I tried a git reset, didnt solve it.

 

errorcode-128.png

 

The issue im having is that my local list of branches is completely empty now. 

Please Help Me I Am getting this error on every next day. And I Have To Take Re-Clone My Project Every Time.

image.png

Check that you have an access to drive E:

The fix did NOT work for me.   Any other suggestions?

 

When I try it, the git reset command gets "fatal: unterminated line in .git/packed-refs"

Works for me. Thanks.

It also worked for me 

I restarted my windows system and then opened the source tree. It is automatically resolved !!

I get this all the time.

I almost hate it already!

Steps to reproduce are simple.

Just create a new branch, commit something, then switch to develop, merge your branch to develop and delete it. And observe the bug.

The only way to fix is to delete the wholerepo fromsourcetreeand add it again.

Can the issue be fixed? Please?

I deleted my project (root folder) and created it again. It was the fastest and simplest way in my case.

Save all you changes, before you delete you project!

Thanks.. It worked.. Sorry for the late reply

rrudnicki Atlassian Team Oct 21, 2015

Hi Ralph, glad to hear that :) If you don't mind, I would kindly ask you to accept it so the same will be visible to others who might be facing the same issue you have inquired.

just did.. sorry :)

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

5,738 views 4 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you