git-remote-https.exe libcurl-4.dll The procedure entry point SSL_CTX_set_alpn_protos could not be located in the dll

I installed SourceTree 1.6.25 on my work computer this morning (fresh install). Upon trying to "clone new" Bitbucket repository, i received the following error:

---------

git-remote-https.exe - entry point not found

The procedure entry point SSL_CTX_set_alpn_protos could not be located in the dynamic link library

C:\Users\myuser\AppData\Local\Atlassian\SourceTree\git_local\mingw32\bin\libcurl-4.dll

----------

 

I've searched my machine for older copies of libcurl-4.dll and no copires are found. I checked the system path for anything suspicious. I've done extensive google searching and I haven't found any answers to this issue.

 

This error is preventing me from cloning any repository. How do I fix this? 

 

7 answers

1 accepted

49 votes
Accepted answer

I've been struggling with similar issue where a fresh install of SourceTree on a different PC failed to clone with an error saying it couldn't find a DLL (specifaclly LIBEAY32.dll). It is all installed and working correctly on another PC. Eventually I found that 37 DLL's are in: C:\Users\myName\AppData\Local\Atlassian\SourceTree\git_local\mingw32\bin

But they should also be found at:

C:\Users\myName\AppData\Local\Atlassian\SourceTree\git_local\mingw32\libexec\git-core

After a Copy 'n' paste of all 37 DLL's into the git-core folder and it is now working. Hope this helps someone.

Thank you Todd Dowty! This worked for me! Is this an installation bug? Should this be elevated to the SourceTree developers somehow? I'm not sure how these issues get fixed permanently.

Thanks a lot mate. It was quick and very helpful.

Beautiful. Had this issue and no help anywhere. I can't imagine how you came up with this solution and just amazing that this can happen with a fresh installation. Thank you thank you thank you.

Thank you very much! It's really helped.

Thank you very much, this helped me too

Thank you so much! 

Thank you mate smile!

Its Working fine...Thanks

Thank you so much! 

Thanks, It solved the problem

Nice find. Did you find this out using Process Monitor by SysInternals? I can confirm too. smile

160405-09-01.jpg

you are my hero today

Had this problem after an upgrade.  Your solution worked for me.  Thank you.

Thanks!  This answer saved my day.

Thank you!!! fixed my of "

HTTPS Protocol not supported or disabled in libcurl"

Thank you very much Todd Dowty!  You solved my problem!
[Note: in my case, the missing DLL's were 38]

If this is an ongoing issue for so many, why doesn't Atlassian release a fix for this?

Thank you!!! It works!!!

Thank you so much!

It worked for me also. Many thanks!

It works for me! thanks man!

You'd think an answer with so many upvotes would get the attention of Atlassian and actually a fix for this in future builds. I hope they are reading and making changes!

Todd you are the Man!  Nice job, worked for me. smile

Thank you very mach!!!! its super!!

Thanks Man, you made my day.!!!

Worked for me aswell. Thx.

I have tried all the suggestions out there and failed. This worked. Thank youuuuuuuuuuuuu

Thank you.

I have to say it is beyond ridiculous that it's been over a year and an issue like this still hasn't been addressed.

Thank you.

Iam use Windows 10 64... 

I ended up dumping SourceTree and gong with GitHub's Windows client. Atlassian should stick to web apps or get a competent Windows team to make SourceTree software. It is quite embarassing they can't get their act together for this software.

Thank you very much.

I've had problem with different dll and the copy 'n paste solve my problem.

My problem was: The procedure entry point EVP_aes_128_ctr could not be located in the dynamic link library, in the library libssh2-1.dll.

I'm just putting here the message and dll to facilitate others who has the same problem.

Again. Thank you.

Thanks!  That worked for me.  Too bad they don't have this bug fixed in over a year.

Awesome quick fix, to the point and accurate. :-)  Thank you!

I ran into the same problem this morning. I fixed it temporarily by installing the CLI Git client from https://git-scm.com/downloads and changing the Git setting in SourceTree to use the system Git client.

 

Not really an answer, but if your under a deadline.

this worked for me, thank you.

I had CLI Git client already installed and switching to the "System Git" instead of Embedded Git work for me as well.  Was struggling with a lot of the "entry point" errors.  Thanks for the suggestion.

ah thank a lot brooo
very thaank 

Try removing libcurl.dll from C:\Windows\sysWOW64 and C:\Windows\System32. Looks like it has libcurl conflict.

--

Dolot

 

 

Yes, this finally did help for the LIBEAY32.dll located in C:\Windows\sysWOW64. Thanks to all!

 

I'm having the same issue, and I don't see libcurl.dll in either of those folders.  Was this ever resolved?

Hi David,

 

Yes it did resolve for me. Please make sure you enter the correct http path from git when inputting to source tree.

I temporarily resolved this issue the same way as Dwayne by not using the built in Git client. I also do not have libcurl.dll in the windows folders above. Some posts I read on other sites said Office 365 (which I have installed) may be causing a conflict. I just installed the latest the SourceTree update and this did not solve the problem. I have not received any information on a fix. This problem is currently unresolved for me. The embedded Git client still will not work.

Todd Dowty,

Thank you I tried what you said and it solved it however I had 38 dlls.

Hint: Use the search bar .dll to mark all fast

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

710 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you