Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


fatal: Authentication Failed



I have been dealing with this issue below: 

fatal: Authentication failed for '

Please note, I have no issues accessing this through the browser. Also, I am authenticating with OAuth in sourcetree.

I have tried all the solutions posted on:

As well as the solution posted on:

To summarize the two threads and to list all the methods I have tried:

Solution A

  1. Navigating to C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree and removing the passwd file.
  2. Doing a Push/Pull will cause a dialog to appear to re-enter your password

Solution B

  1. Make sure SourceTree is closed
  2. Make sure the files are backed up in the following folders before removing the files
  3. Remove files "bookmarks.xml", "opentabs.xml", "userhosts" in C:\Users\<username>\AppData\Local\Atlassian\SourceTree\
    1. NOTE: I could not find the userhosts file in my version
  4. Remove file in C:\Users\<username>\AppData\Local\Atlassian\SourceTree.exe<random_string>\<version_number>\user.config
  5. Open SourceTree again to test if it worked or not.

Solution C

  1. Go to Tools > Options >  Authentication
  2. Click on Account, then click Delete
  3. Click on Add to re-add Account

Solution D

  1. Go to Terminal
  2. Write GIT PUSH (or GIT PULL)
  3. Enter Username/Password when prompted

Solution E

  1. Go to Control Panel\User Accounts\Credential Manager
  2. Click Windows Credentials
  3. Re-enter all sourcetree and git credentials

Solution F

  1. Uninstall Sourcetree
  2. Install Sourcetree

Again, none of these solutions worked for me, but have had success for others. If you have any other idea that could help, I'd be very grateful.

Thank you for your help.


SourceTree Version: 3.4.8



How I got it to work:

  1. Log into atlassian
  2. Go to personal settings
  3. Go to App Passwords
  4. Generate an App Password with permissions as you see fit, make sure to take a copy of the password
  5. Navigate to C:\Users\USERNAME\AppData\Local\Atlassian\SourceTree and removing the passwd file.
  6. Do a Push/Pull in SourceTree
  7. Enter your App Password




0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events