Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

error 403: authenticate with App Password

Error Message:

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags origin feature/x:feature/x
remote: Because you enabled two-step verification for your Atlassian account, you'll need to authenticate with an app password. Create an app password at
fatal: unable to access '': The requested URL returned error: 403


However despite following the documentation and changing my authentication type to Basic with username and app password (with "Authentication OK" and green tick) it still spits out this error message after restarting.

Using Windows 10.

I've tried deleting pswd in AppData.


6 answers

1 accepted

13 votes
Answer accepted

This worked for me where I have cloned the repo locally before creating the app passwords.

Given you have the app password created in your bitbucket repo

Then update your local git repo as below

git remote set-url origin

worked just fine, thanks

Like Gopinath Emmidisetty likes this
Like Gopinath Emmidisetty likes this
Like Gopinath Emmidisetty likes this

Thanks Gopinath🙌😍 - following command works for me.

git remote set-url origin

Happy Christmas 🌲

Like Gopinath Emmidisetty likes this

Ignore this answer, I initiallly thought I had it fixed but the problem still persists.

Same problem.

When two-step verification is enabled, I cannot do any operation in the Sourcetree software. Whether it is through the classic interface or the terminal the error is the same, "error 403".

I tried deleting my account in Tools -> Options, but it doesn't fix the problem. I also tried to log out and log back into my Atlassian account through the internet browser.
On the other hand, if I cancel the two-step verification, it works perfectly well.

A solution ?

I was having the same problem.

Had to cancel the two-step authentication to be able to work.

Like Camilo Cano likes this

how to cancel the two-step verification?

Now I'm not sure if I had it enabled in my Bitbucket account or Atlassian account, but you can check for yourself in the following links:





Hope it helps.

I just encountered this problem too.  Set up an app password for Sourcetree, turned on TSV, and then couldn't access BitBucket through Sourcetree.  Turned off TSV and could access BB fine from Sourcetree.  When will this error be fixed?

Having exactly the same problem. 

Did someone managed to make this work? Or cancelling 2FA is the only option?

I have this problem, too and it's very annoying. I have already refreshed my password and also set the user with this password on the repository and it still shows this error.

Maybe I should turn off two factor authentication because of this but that's not ideal.

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events