Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


cant connect to a azure devops git repo using PAT


Ok, I have been using git with github, bitbucket etc for years and never had an issue.

Today I tried the task of simply cloning a project from our orgs dev ops git repo in Azure.

I think I have tried everything, and cant figure it out.

On the mac source tree, if I do new->clone URL

It asks for source url, dest path and name.

For URL I enter:

It then fills out a default desination path and name, which I cant change as it pops up with a login window with username and password.

Meanwhile in the azure repo, I have created a PAT with full access to the repo.  The PAT is a long string.

I have tried the PAT for user name and password (as defined in the source tree docs), just for password, with my azure login details, with my azure user and the PAT as the password everything. No matter what I put, I get the error: 

"this is not a valid source path URL". Well it is!

If I try the same thing in windows, I get "failed to login for user [PAT]"

Our org has disabled "alternative credentials" so PAT is the only option.

Any suggestions?

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events