Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,461,785
Community Members
 
Community Events
176
Community Groups

can't push via Sourcetree after setting up Visual Studio Code (remote: Password authentication is t)

Hey people,

 

I created my own repos. in github. I was able to commit and push and pull via Sourcetree just fine.

I discovered Visual Studio Code can also push changes for me. For that I had to enter a token. I created that token n Github and VSC is working just fine.

I still want to push via SourceTree though. But everytime I get the following message

 

git -c diff.mnemonicprefix=false -c core.quotepath=false --no-optional-locks push -v --tags origin master:master
fatal: credential-cache unavailable; no unix socket support
remote: Password authentication is temporarily disabled as part of a brownout. Please use a personal access token instead.
remote: Please see https://github.blog/2020-07-30-token-authentication-requirements-for-api-and-git-operations/ for more information.
fatal: unable to access 'https://github.com/kellerSepp/karriereTutorHTMLCSS.git/': The requested URL returned error: 403

Pushing to https://github.com/kellerSepp/karriereTutorHTMLCSS.git
Completed with errors, see above.

 

I sort of get it has to do something with the token. So I checked Tools->Options->Authentification and edited the git account entry:

I tried HTTPS & SSH ... Credentials :OAuth -> refresh OAuth Token

I see the green check for "Authentification ok" but I still can't push.

I am trying to solve this problem for 2.5 h...

can someone maybe please help me?

 

thank you

 

 

2 answers

1 accepted

2 votes
Answer accepted

Hey people,

 

short update.... I just went to shop some groceries, came back and tried to push my content again. Now it works just fine. I didn't do anything since publishing this post .. besides groceries ..

apperantly I have to wait until the gods of code allow me to push things.

So.. I see this case as solved. Sorry, but I have no clue why it works now .

I am experiencing the same issue.

Any idea how to speed it up?

I think there might be some sort of unreported GtiHub outage happening.  I am experiencing this same error message trying to pull from GitHub on another piece of software.

Like Yanir Calisar likes this

It says they are having a brownout so they've disabled password authentication. Perhaps they are disabling things they are planning on sunsetting soon in order to save power. 

As Github earlier said we will no longer accept account passwords when authenticating with the REST API and will require the use of token-based authentication

to solve Password authentication is temporarily disabled as part of a brownout. Please use a personal access token instead of this error you just need to create a new token and then Update the remote URL.

That’s It. Your error will be solved.

Here Is explained Solution [Solved] Password authentication is temporarily disabled as part of a brownout. Please use a personal access token instead

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events